summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-29/mythweb
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-10-25 17:05:26 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-10-25 17:05:26 (GMT)
commit7b41a9288f5d1332c8136df798bb8ca2465bc21c (patch)
tree8551ce40362a5d6191c918f1e5652f9350cce09f /abs/core/mythtv/stable-29/mythweb
parent5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (diff)
parent0a4d5cece8f6b3148a61c6358026fdf2eb81cdb2 (diff)
downloadlinhes_pkgbuild-7b41a9288f5d1332c8136df798bb8ca2465bc21c.zip
linhes_pkgbuild-7b41a9288f5d1332c8136df798bb8ca2465bc21c.tar.gz
linhes_pkgbuild-7b41a9288f5d1332c8136df798bb8ca2465bc21c.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/mythtv/stable-29/mythweb')
-rw-r--r--abs/core/mythtv/stable-29/mythweb/Channel.php_remove_small_icons.patch14
-rw-r--r--abs/core/mythtv/stable-29/mythweb/PKGBUILD6
2 files changed, 18 insertions, 2 deletions
diff --git a/abs/core/mythtv/stable-29/mythweb/Channel.php_remove_small_icons.patch b/abs/core/mythtv/stable-29/mythweb/Channel.php_remove_small_icons.patch
new file mode 100644
index 0000000..f786d15
--- /dev/null
+++ b/abs/core/mythtv/stable-29/mythweb/Channel.php_remove_small_icons.patch
@@ -0,0 +1,14 @@
+diff --git a/modules/tv/classes/Channel.php b/modules/tv/classes/Channel.php
+index a4350283..be45b6ff 100644
+--- ./modules/tv/classes/Channel.php
++++ ./modules/tv/classes/Channel.php
+@@ -113,6 +113,9 @@ class Channel extends MythBase {
+ foreach ($channel_data AS $key => $value)
+ $this->$key = $value;
+ $this->icon = 'data/tv_icons/'.basename($channel_data['icon']);
++ // Remove icons smaller than 100 bytes
++ if (file_exists($this->icon) && filesize($this->icon) < 100)
++ unlink($this->icon);
+ // Try to copy over any missing channel icons
+ if ($channel_data['icon'] && !file_exists($this->icon)) {
+ // Local file?
diff --git a/abs/core/mythtv/stable-29/mythweb/PKGBUILD b/abs/core/mythtv/stable-29/mythweb/PKGBUILD
index f83912e..7057f25 100644
--- a/abs/core/mythtv/stable-29/mythweb/PKGBUILD
+++ b/abs/core/mythtv/stable-29/mythweb/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythweb
pkgver=29
-pkgrel=5
+pkgrel=6
commit_hash=`cat ../git_src/git_hash_web`
pkgdesc="Web interface for MythTV's backend, $commit_hash"
arch=('x86_64')
@@ -10,7 +10,8 @@ depends=('lighttpd' "mythtv>=${pkgver}" 'php' 'supplemental-web')
groups=('mythtv-extras')
install=mythweb.install
-patches=('video.css.patch')
+patches=('video.css.patch'
+ 'Channel.php_remove_small_icons.patch')
source=(`echo ${patches[@]:0}`
'mythweb.include'
'mythweb_gen_light.conf')
@@ -54,5 +55,6 @@ package() {
install -D -m0744 ${srcdir}/mythweb_gen_light.conf ${pkgdir}/etc/gen_light_conf.d/mythweb.conf
}
md5sums=('668a36e404c8254f56e7a7304e655332'
+ '333d145899a1b48a7648d933344ee9ed'
'7645a6399434cbba35639713ac5d88e0'
'df190116b3aba35720fb6631885f973f')