summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/trunk/mythbrowser/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/core/mythtv/trunk/mythbrowser/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/core/mythtv/trunk/mythbrowser/PKGBUILD')
-rw-r--r--abs/core/mythtv/trunk/mythbrowser/PKGBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/abs/core/mythtv/trunk/mythbrowser/PKGBUILD b/abs/core/mythtv/trunk/mythbrowser/PKGBUILD
deleted file mode 100644
index fdcefe0..0000000
--- a/abs/core/mythtv/trunk/mythbrowser/PKGBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-pkgname=mythbrowser-svn
-pkgver=23790
-pkgrel=1
-pkgdesc="Mini web browser for MythTV"
-url="http://www.mythtv.org"
-license="GPL"
-arch=('i686' 'x86_64')
-
-depends=('mythtv-svn' 'wget')
-conflicts=('mythbrowser')
-groups=('mythtv-extras-svn')
-
-patches=()
-source=(`echo ${patches[@]:0}`)
-
-_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
-_svnmod=mythplugins
-
-
-build() {
-
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- svn revert -R $_svnmod
-
- cd $startdir/src/$_svnmod
-
- echo "--------------------------applying patches----------------------------------------------------"
- for i in `echo ${patches[@]:0} `
- do
- echo applying $i
- echo "-----------------------------"
- patch -Np0 -i ${startdir}/src/$i || return 1
- done
- echo "--------------------------done applying patches-----------------------------------------------"
-
- [ "$CARCH" = "i686" ] && ARCH="i686"
- [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
-
- # clean up
- make distclean
-
- # configure
- ./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
- --enable-mythbrowser || return 1
-
- # build and install
- . /etc/profile
- make || return 1
- make INSTALL_ROOT=$startdir/pkg install || return 1
-
-}