summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-28 19:08:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-28 19:08:23 (GMT)
commit4070bdaf7a8df038c73e67f442e9d056c345fae4 (patch)
tree99236e7bc59f066d986193c6e2b139edcea5ef79 /abs/core/mythtv
parent6a90696c77930083a10e261ff09494455d3f9d07 (diff)
downloadlinhes_pkgbuild-4070bdaf7a8df038c73e67f442e9d056c345fae4.zip
linhes_pkgbuild-4070bdaf7a8df038c73e67f442e9d056c345fae4.tar.gz
linhes_pkgbuild-4070bdaf7a8df038c73e67f442e9d056c345fae4.tar.bz2
mythtv & mythplugins: update to latest fixes and add patch for libvpx
Diffstat (limited to 'abs/core/mythtv')
-rw-r--r--abs/core/mythtv/stable-0.27/git_src/git_hash2
-rw-r--r--abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD2
-rw-r--r--abs/core/mythtv/stable-0.27/mythtv/PKGBUILD4
-rw-r--r--abs/core/mythtv/stable-0.27/mythtv/ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch41
4 files changed, 46 insertions, 3 deletions
diff --git a/abs/core/mythtv/stable-0.27/git_src/git_hash b/abs/core/mythtv/stable-0.27/git_src/git_hash
index fdf94d2..73d312f 100644
--- a/abs/core/mythtv/stable-0.27/git_src/git_hash
+++ b/abs/core/mythtv/stable-0.27/git_src/git_hash
@@ -1 +1 @@
-a62fc0da9e9d8152a5b83cb6e8898faf67d6cbab
+6883c2052e9c4a3cac0ab0daa528298b4ff9f8b2
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
index f8056c8..19df82e 100644
--- a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('mytharchive'
'mythweather'
'mythzoneminder')
pkgver=0.27.5
-pkgrel=15
+pkgrel=16
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
license=('GPL')
diff --git a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
index f157f21..ef23018 100644
--- a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythtv
pkgver=0.27.5
-pkgrel=15
+pkgrel=16
commit_hash=`cat ../git_src/git_hash`
pkgdesc="A Homebrew PVR project $commit_hash"
arch=('i686' 'x86_64')
@@ -20,6 +20,7 @@ backup=()
install='mythtv.install'
patches=('myth_settings.patch'
+ 'ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch'
'videoAlwaysUseBookmark.patch'
'fixQTvirtualkeyboard.patch'
'suggestedstarttime.patch.v1'
@@ -105,6 +106,7 @@ package() {
}
md5sums=('5f3e43567e62afe17bad39f5a9b604cf'
+ 'c09908eb42a8c842d6528bfe436dc4b2'
'41098e898361a5a3cde3eaae358482a8'
'a853dff0f5c92ca58fcc1e389cd16266'
'35a7fd3e3057691e3b1bf355bb9e8b16'
diff --git a/abs/core/mythtv/stable-0.27/mythtv/ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch b/abs/core/mythtv/stable-0.27/mythtv/ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
new file mode 100644
index 0000000..e142829
--- /dev/null
+++ b/abs/core/mythtv/stable-0.27/mythtv/ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
@@ -0,0 +1,41 @@
+From 6540fe04a3f9a11ba7084a49b3ee5fa2fc5b32ab Mon Sep 17 00:00:00 2001
+From: James Zern <jzern@google.com>
+Date: Mon, 19 Oct 2015 22:44:11 -0700
+Subject: [PATCH] libvpxenc: remove some unused ctrl id mappings
+
+VP8E_UPD_ENTROPY, VP8E_UPD_REFERENCE, VP8E_USE_REFERENCE were removed
+from libvpx and the remaining values were never used here
+
+Reviewed-by: Michael Niedermayer <michael@niedermayer.cc>
+Signed-off-by: James Zern <jzern@google.com>
+---
+ libavcodec/libvpxenc.c | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/libavcodec/libvpxenc.c b/libavcodec/libvpxenc.c
+index 5f39783..992122c 100644
+--- a/mythtv/external/FFmpeg/libavcodec/libvpxenc.c
++++ b/mythtv/external/FFmpeg/libavcodec/libvpxenc.c
+@@ -104,19 +104,11 @@ typedef struct VP8EncoderContext {
+
+ /** String mappings for enum vp8e_enc_control_id */
+ static const char *const ctlidstr[] = {
+- [VP8E_UPD_ENTROPY] = "VP8E_UPD_ENTROPY",
+- [VP8E_UPD_REFERENCE] = "VP8E_UPD_REFERENCE",
+- [VP8E_USE_REFERENCE] = "VP8E_USE_REFERENCE",
+- [VP8E_SET_ROI_MAP] = "VP8E_SET_ROI_MAP",
+- [VP8E_SET_ACTIVEMAP] = "VP8E_SET_ACTIVEMAP",
+- [VP8E_SET_SCALEMODE] = "VP8E_SET_SCALEMODE",
+ [VP8E_SET_CPUUSED] = "VP8E_SET_CPUUSED",
+ [VP8E_SET_ENABLEAUTOALTREF] = "VP8E_SET_ENABLEAUTOALTREF",
+ [VP8E_SET_NOISE_SENSITIVITY] = "VP8E_SET_NOISE_SENSITIVITY",
+- [VP8E_SET_SHARPNESS] = "VP8E_SET_SHARPNESS",
+ [VP8E_SET_STATIC_THRESHOLD] = "VP8E_SET_STATIC_THRESHOLD",
+ [VP8E_SET_TOKEN_PARTITIONS] = "VP8E_SET_TOKEN_PARTITIONS",
+- [VP8E_GET_LAST_QUANTIZER] = "VP8E_GET_LAST_QUANTIZER",
+ [VP8E_SET_ARNR_MAXFRAMES] = "VP8E_SET_ARNR_MAXFRAMES",
+ [VP8E_SET_ARNR_STRENGTH] = "VP8E_SET_ARNR_STRENGTH",
+ [VP8E_SET_ARNR_TYPE] = "VP8E_SET_ARNR_TYPE",
+--
+1.7.10.4
+