summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-10-10 22:28:43 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-10-10 22:28:43 (GMT)
commit60529a83d55a53856744a3aabf41304c946be0cc (patch)
tree4f984d7790287872c4ec8d55b0f8cb5b8b87e407 /abs/core/mythtv
parentd4b8c5c7d1c30c71c85d0e36251e9af14c78879e (diff)
downloadlinhes_pkgbuild-60529a83d55a53856744a3aabf41304c946be0cc.zip
linhes_pkgbuild-60529a83d55a53856744a3aabf41304c946be0cc.tar.gz
linhes_pkgbuild-60529a83d55a53856744a3aabf41304c946be0cc.tar.bz2
mythtv: add patch to search selected grabber
This allows the inetref to be ttvdb.py_ and it will only search the tv db.
Diffstat (limited to 'abs/core/mythtv')
-rw-r--r--abs/core/mythtv/stable-0.28/mythtv/PKGBUILD4
-rw-r--r--abs/core/mythtv/stable-0.28/mythtv/searchMetatdataSelectedGrabber.patch18
2 files changed, 21 insertions, 1 deletions
diff --git a/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD
index 3b1f20d..ecc5ca2 100644
--- a/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythtv
pkgver=0.28
-pkgrel=19
+pkgrel=20
commit_hash=`cat ../git_src/git_hash`
pkgdesc="A Homebrew PVR project $commit_hash"
arch=('i686' 'x86_64')
@@ -29,6 +29,7 @@ patches=(
'disable_mythnotification_tuner_failure.patch'
'tv.cpp_fix_caps.patch'
'add_categorytype_Program.pm.patch'
+ 'searchMetatdataSelectedGrabber.patch'
)
optdepends=()
@@ -112,4 +113,5 @@ md5sums=('e30b482dcd5f3e71c6419fd753bab2b1'
'1cd668136deea20efb79cf3e6310effc'
'62c42b1043ebf65959fa9eced9ca3ed8'
'a38f26576662afdc02d11c7096839321'
+ '0f674b9cad031ba1e03aaf6b5ee1499f'
'cc9e81a297f82e9df4ad72428c4f37c6')
diff --git a/abs/core/mythtv/stable-0.28/mythtv/searchMetatdataSelectedGrabber.patch b/abs/core/mythtv/stable-0.28/mythtv/searchMetatdataSelectedGrabber.patch
new file mode 100644
index 0000000..41e0871
--- /dev/null
+++ b/abs/core/mythtv/stable-0.28/mythtv/searchMetatdataSelectedGrabber.patch
@@ -0,0 +1,18 @@
+--- src/mythtv/libs/libmythmetadata/metadatadownload.cpp.orig 2016-10-06 19:52:36.807746878 +0000
++++ src/mythtv/libs/libmythmetadata/metadatadownload.cpp 2016-10-06 19:42:06.045651726 +0000
+@@ -517,6 +517,7 @@
+
+ // initial search mode
+ if (!lookup->GetInetref().isEmpty() && lookup->GetInetref() != "00000000" &&
++ !lookup->GetInetref().endsWith("_") &&
+ (lookup->GetStep() == kLookupSearch || lookup->GetStep() == kLookupData))
+ {
+ // with inetref
+@@ -575,6 +576,7 @@
+
+ // initial search mode
+ if (!lookup->GetInetref().isEmpty() && lookup->GetInetref() != "00000000" &&
++ !lookup->GetInetref().endsWith("_") &&
+ (lookup->GetStep() == kLookupSearch || lookup->GetStep() == kLookupData))
+ {
+ // with inetref