summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2010-12-30 00:31:58 (GMT)
committerCecil <knoppmyth@gmail.com>2010-12-30 00:31:58 (GMT)
commit6bc8f86e4478eed52a0d76c142224de652cad354 (patch)
treeb0739ccf5f57a8c59ab413ef67bfc53899645350 /abs/core/mythtv
parentf1216cf18eff51debb106a85fd7140080bbb4306 (diff)
downloadlinhes_pkgbuild-6bc8f86e4478eed52a0d76c142224de652cad354.zip
linhes_pkgbuild-6bc8f86e4478eed52a0d76c142224de652cad354.tar.gz
linhes_pkgbuild-6bc8f86e4478eed52a0d76c142224de652cad354.tar.bz2
mythtv:completes the change from SVN to GIT.
Diffstat (limited to 'abs/core/mythtv')
-rwxr-xr-xabs/core/mythtv/stable-0.24/mythtv/PKGBUILD28
-rw-r--r--abs/core/mythtv/stable-0.24/mythtv/git_version.patch12
2 files changed, 21 insertions, 19 deletions
diff --git a/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
index e7c6359..0969b1d 100755
--- a/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=mythtv
-pkgver=20101229
-pkgrel=1
+pkgver=0.24
+pkgrel=11
pkgdesc="A Homebrew PVR project"
arch=('i686' 'x86_64')
url="http://www.mythtv.org/"
@@ -23,33 +23,21 @@ groups=('pvr')
#options=(!strip)
#MAKEFLAGS="-j6"
install='mythtv.install'
-patchs=('smolt_jump.patch')
+patchs=('smolt_jump.patch' 'git_version.patch')
optdepends=('xmltv: to download tv listings')
#replaces=('mythtv-contrib')
#conflicts=('mythtv-contrib')
-source=('mythbackend' 'myth.sh' `echo ${patchs[@]:0}` 'mythbackend.lr' 'mythfrontend.lr' 'pretty')
+source=(http://knoppmyth.net/R6/sources/mythtv-0.24-fixes.tar.bz2
+ 'mythbackend' 'myth.sh' `echo ${patchs[@]:0}` 'mythbackend.lr' 'mythfrontend.lr' 'pretty')
_gitroot="https://github.com/MythTV/mythtv.git"
_gitname="${pkgname}"
build() {
- # get clean copy from SVN repo
- if [ -d "${srcdir}/${pkgname}" ]
- then
cd "${srcdir}/${pkgname}"/mythtv
- msg "Clean up previous build..."
- #make distclean
- cd "${srcdir}/${pkgname}"
msg "Updating from GIT..."
#git checkout -b 0.24-fixes origin/fixes/0.24
git pull
msg "The local files are updated."
- else
- cd "${srcdir}"
- msg "Cloning from GIT..."
- git clone $_gitroot $_gitname
- cd "${srcdir}/${pkgname}" && git checkout origin/fixes/0.24
- fi
- cd "${srcdir}/${pkgname}"/mythtv
# apply patches
echo "--------------------------applying patches----------------------------------------------------"
for i in `echo ${patchs[@]:0} `
@@ -80,7 +68,7 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}"/mythtv
# basic install
make INSTALL_ROOT="${pkgdir}" install
# install contrib files
@@ -107,9 +95,11 @@ package() {
mkdir -p ${pkgdir}/etc/cron.hourly/
install -m0755 ${srcdir}/pretty ${pkgdir}/etc/cron.hourly/
}
-md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
+md5sums=('91488a6b1b05d14c5c5c601908b699e5'
+ '7ef6de58240e7aad389a0b13d91b1cf6'
'2babd4b8e146a7538d18dcd55695b0be'
'a837de9ccc201994320071e48952b17d'
+ 'ca4a87383c47f51c71151c8fb50f38cc'
'f735805a80b0d1180dee01f9df1b7004'
'f407d6af23e74a49540755420f84fa58'
'5469d9921b726db750b991c87d226158')
diff --git a/abs/core/mythtv/stable-0.24/mythtv/git_version.patch b/abs/core/mythtv/stable-0.24/mythtv/git_version.patch
new file mode 100644
index 0000000..096a644
--- /dev/null
+++ b/abs/core/mythtv/stable-0.24/mythtv/git_version.patch
@@ -0,0 +1,12 @@
+diff -ruaN mythtv.orig/mythtv/version.sh mythtv/mythtv/version.sh
+--- version.sh 2010-12-29 22:27:10.000000000 +0000
++++ version.sh 2010-12-29 23:36:19.000000000 +0000
+@@ -22,7 +22,7 @@
+
+ cd ${GITTREEDIR}
+
+-SOURCE_VERSION=$(git describe --dirty || echo Unknown)
++SOURCE_VERSION=$(git describe | cut -d- -f 3 || echo Unknown)
+
+ case "${SOURCE_VERSION}" in
+ exported|Unknown)