summaryrefslogtreecommitdiffstats
path: root/abs/core/ncurses
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/ncurses
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/ncurses')
-rw-r--r--abs/core/ncurses/PKGBUILD75
-rw-r--r--abs/core/ncurses/ncurses.install9
2 files changed, 84 insertions, 0 deletions
diff --git a/abs/core/ncurses/PKGBUILD b/abs/core/ncurses/PKGBUILD
new file mode 100644
index 0000000..052881e
--- /dev/null
+++ b/abs/core/ncurses/PKGBUILD
@@ -0,0 +1,75 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: judd <jvinet@zeroflux.org>
+pkgname=ncurses
+pkgver=5.6
+pkgrel=15
+pkgdesc="A System V Release 4.0 curses emulation library"
+arch=(i686 x86_64)
+url="http://www.gnu.org/software/ncurses/ncurses.html"
+license=('MIT')
+groups=('base')
+depends=('glibc')
+source=(ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('b6593abe1089d6aab1551c105c9300e3')
+options=(!makeflags)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ # The chtype/mmask-t settings below are to retain ABI compat
+ # with ncurses-5.4 so dont change em !
+ # we should test in next update if we can drop it.
+if [ "$CARCH" == "x86_64" ]; then
+ ./configure --prefix=/usr \
+ --with-shared --with-normal --without-debug --without-ada \
+ --with-install-prefix=$startdir/pkg \
+ --with-chtype='long' --with-mmask-t='long'
+ else
+ ./configure --prefix=/usr \
+ --with-shared --with-normal --without-debug --without-ada \
+ --with-install-prefix=$startdir/pkg
+fi
+ make || return 1
+ make install
+ mkdir -p $startdir/pkg/lib
+ cd $startdir/pkg/usr/lib
+ mv libncurses.so.$pkgver ../../lib
+ ln -sf ../../lib/libncurses.so.$pkgver libncurses.so.$pkgver
+ cd $startdir/pkg/lib
+ ln -sf libncurses.so.$pkgver libncurses.so.5
+ rm -f $startdir/pkg/lib/libcurses.so
+
+ # build unicode support libs
+ cd $startdir/src/$pkgname-$pkgver
+ make clean
+if [ "$CARCH" == "x86_64" ]; then
+ ./configure --prefix=/usr \
+ --with-shared --with-normal --without-debug --without-ada \
+ --with-install-prefix=$startdir/pkg --enable-widec \
+ --with-chtype='long' --with-mmask-t='long'
+ else
+ ./configure --prefix=/usr \
+ --with-shared --with-normal --without-debug --without-ada \
+ --with-install-prefix=$startdir/pkg --enable-widec
+fi
+ make || return 1
+ make install
+
+ mkdir $startdir/pkg/usr/include/ncursesw
+ ln -sf /usr/include/ncurses.h $startdir/pkg/usr/include/ncursesw
+ # fix library for tput, we call it in initscripts!
+ cd $startdir/pkg/usr/lib
+ mv libncursesw.so.$pkgver ../../lib
+ ln -sf ../../lib/libncursesw.so.$pkgver libncursesw.so.$pkgver
+ cd $startdir/pkg/lib
+ ln -sf libncursesw.so.$pkgver libncursesw.so.5
+
+ # install tput to /bin
+ mkdir $startdir/pkg/bin/
+ mv $startdir/pkg/usr/bin/tput $startdir/pkg/bin/tput
+
+ # install license, rip it from the readme
+ cd $startdir/src/$pkgname-$pkgver
+ mkdir -p $startdir/pkg/usr/share/licenses/$pkgname
+ grep -B 100 '$Id' README > $startdir/pkg/usr/share/licenses/$pkgname/license.txt
+}
diff --git a/abs/core/ncurses/ncurses.install b/abs/core/ncurses/ncurses.install
new file mode 100644
index 0000000..6b5a1dc
--- /dev/null
+++ b/abs/core/ncurses/ncurses.install
@@ -0,0 +1,9 @@
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ echo ">> You can safely ignore any \"cannot open shared object\" errors you see above"
+}
+
+op=$1
+shift
+$op $*