summaryrefslogtreecommitdiffstats
path: root/abs/core/ncurses
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-05 15:39:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-05 15:39:40 (GMT)
commit14513c73d75016aadb7217d3d7a23aa60406a92f (patch)
tree0d619502030668dacfcad69a0ff68cf05ea0252f /abs/core/ncurses
parent966f958e2c7d3d9abd4c0818da00f386685ed21c (diff)
downloadlinhes_pkgbuild-14513c73d75016aadb7217d3d7a23aa60406a92f.zip
linhes_pkgbuild-14513c73d75016aadb7217d3d7a23aa60406a92f.tar.gz
linhes_pkgbuild-14513c73d75016aadb7217d3d7a23aa60406a92f.tar.bz2
ncurses: update ref #647
Diffstat (limited to 'abs/core/ncurses')
-rw-r--r--abs/core/ncurses/PKGBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/abs/core/ncurses/PKGBUILD b/abs/core/ncurses/PKGBUILD
index c0fd425..017e900 100644
--- a/abs/core/ncurses/PKGBUILD
+++ b/abs/core/ncurses/PKGBUILD
@@ -1,26 +1,39 @@
-# $Id: PKGBUILD 19129 2008-11-15 00:00:47Z allan $
+# $Id: PKGBUILD 77821 2010-04-18 09:29:42Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=ncurses
pkgver=5.7
-pkgrel=2
+pkgrel=3
pkgdesc="System V Release 4.0 curses emulation library"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/ncurses/"
license=('MIT')
-groups=('base')
depends=('glibc')
source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
md5sums=('cce05daf61a64501ef6cd8da1f727ec6')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- ./configure --prefix=/usr --mandir=/usr/share/man \
+ cd ${srcdir}/
+ mkdir ncurses{,w}-build
+
+ cd ${srcdir}/ncursesw-build
+ ../${pkgname}-${pkgver}/configure --prefix=/usr --mandir=/usr/share/man \
--with-shared --with-normal --without-debug --without-ada \
--with-install-prefix=${pkgdir} --enable-widec
make || return 1
+
+ # libncurses.so.5 for external binary support
+ cd ${srcdir}/ncurses-build
+ [ $CARCH = "x86_64" ] && CONFIGFLAG="--with-chtype=long"
+ ../${pkgname}-${pkgver}/configure --prefix=/usr \
+ --with-shared --with-normal --without-debug --without-ada \
+ --with-install-prefix=${pkgdir} $CONFIGFLAG
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/ncursesw-build
make install
# move libraries needed for boot to /lib (we call tput in initscripts)
@@ -47,12 +60,8 @@ build() {
ln -sf libncursesw.a ${pkgdir}/usr/lib/libcursesw.a
ln -sf libncurses.a ${pkgdir}/usr/lib/libcurses.a
- # Install libncurses.so.5 for external binary support
- ./configure --prefix=/usr \
- --with-shared --with-normal --without-debug --without-ada \
- --with-install-prefix=${pkgdir}
- make || return 1
-
+ # non-widec compatibility library
+ cd ${srcdir}/ncurses-build
install -Dm755 lib/libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.${pkgver}
ln -sf libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.5