summaryrefslogtreecommitdiffstats
path: root/abs/core/ncurses
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/core/ncurses
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/core/ncurses')
-rw-r--r--abs/core/ncurses/ChangeLog9
-rw-r--r--abs/core/ncurses/PKGBUILD48
-rw-r--r--abs/core/ncurses/ncurses.install9
3 files changed, 22 insertions, 44 deletions
diff --git a/abs/core/ncurses/ChangeLog b/abs/core/ncurses/ChangeLog
deleted file mode 100644
index f52c19c..0000000
--- a/abs/core/ncurses/ChangeLog
+++ /dev/null
@@ -1,9 +0,0 @@
-2008-11-15 Allan McRae <allan@archlinux.org>
- * ncurses-5.7-2
- * fix installation of non-wide charater libraries (FS#12124)
-
-2008-11-03 Allan McRae <allan@archlinux.org>
- * ncurses-5.7-1
- * upstream update
- * remove coverity patch (included upstream)
- * enable makeflags
diff --git a/abs/core/ncurses/PKGBUILD b/abs/core/ncurses/PKGBUILD
index 017e900..b55c210 100644
--- a/abs/core/ncurses/PKGBUILD
+++ b/abs/core/ncurses/PKGBUILD
@@ -1,27 +1,30 @@
-# $Id: PKGBUILD 77821 2010-04-18 09:29:42Z allan $
+# $Id: PKGBUILD 150103 2012-02-12 13:47:59Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=ncurses
-pkgver=5.7
+pkgver=5.9
pkgrel=3
pkgdesc="System V Release 4.0 curses emulation library"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/ncurses/"
license=('MIT')
depends=('glibc')
-source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('cce05daf61a64501ef6cd8da1f727ec6')
+source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.sig})
+md5sums=('8cb9c412e5f2d96bc6f459aa8c6282a1'
+ '014ffdbbfec6d41a9a89d6cbe6434638')
build() {
cd ${srcdir}/
mkdir ncurses{,w}-build
-
+
cd ${srcdir}/ncursesw-build
../${pkgname}-${pkgver}/configure --prefix=/usr --mandir=/usr/share/man \
--with-shared --with-normal --without-debug --without-ada \
- --with-install-prefix=${pkgdir} --enable-widec
- make || return 1
+ --with-install-prefix=${pkgdir} --enable-widec \
+ --enable-pc-files
+ # add --enable-ext-colors with next soname bump
+ make
# libncurses.so.5 for external binary support
cd ${srcdir}/ncurses-build
@@ -29,41 +32,34 @@ build() {
../${pkgname}-${pkgver}/configure --prefix=/usr \
--with-shared --with-normal --without-debug --without-ada \
--with-install-prefix=${pkgdir} $CONFIGFLAG
- make || return 1
+ make
}
package() {
cd ${srcdir}/ncursesw-build
make install
- # move libraries needed for boot to /lib (we call tput in initscripts)
- install -dm755 ${pkgdir}/lib
- mv ${pkgdir}/usr/lib/libncursesw.so.5* ${pkgdir}/lib
- ln -sf ../../lib/libncursesw.so.5 ${pkgdir}/usr/lib/libncursesw.so
-
# Fool packages looking to link to non-wide-character ncurses libraries
- for lib in curses ncurses form panel menu ; do \
- rm -f ${pkgdir}/usr/lib/lib${lib}.so ; \
- echo "INPUT(-l${lib}w)" >${pkgdir}/usr/lib/lib${lib}.so ; \
- ln -sf lib${lib}w.a ${pkgdir}/usr/lib/lib${lib}.a ; \
+ for lib in ncurses form panel menu; do
+ echo "INPUT(-l${lib}w)" >${pkgdir}/usr/lib/lib${lib}.so
+ ln -s lib${lib}w.a ${pkgdir}/usr/lib/lib${lib}.a
done
- ln -sf libncurses++w.a ${pkgdir}/usr/lib/libncurses++.a
+ ln -s libncurses++w.a ${pkgdir}/usr/lib/libncurses++.a
- # install tput to /bin
- install -dm755 ${pkgdir}/bin/
- mv ${pkgdir}/usr/bin/tput ${pkgdir}/bin/tput
+ for lib in ncurses ncurses++ form panel menu; do
+ ln -s ${lib}w.pc ${pkgdir}/usr/lib/pkgconfig/${lib}.pc
+ done
# Some packages look for -lcurses during build
- rm -f ${pkgdir}/usr/lib/libcursesw.so
echo "INPUT(-lncursesw)" >${pkgdir}/usr/lib/libcursesw.so
- ln -sf libncurses.so ${pkgdir}/usr/lib/libcurses.so
- ln -sf libncursesw.a ${pkgdir}/usr/lib/libcursesw.a
- ln -sf libncurses.a ${pkgdir}/usr/lib/libcurses.a
+ ln -s libncurses.so ${pkgdir}/usr/lib/libcurses.so
+ ln -s libncursesw.a ${pkgdir}/usr/lib/libcursesw.a
+ ln -s libncurses.a ${pkgdir}/usr/lib/libcurses.a
# non-widec compatibility library
cd ${srcdir}/ncurses-build
install -Dm755 lib/libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.${pkgver}
- ln -sf libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.5
+ ln -s libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.5
# install license, rip it from the readme
cd ${srcdir}/${pkgname}-${pkgver}
diff --git a/abs/core/ncurses/ncurses.install b/abs/core/ncurses/ncurses.install
deleted file mode 100644
index 6b5a1dc..0000000
--- a/abs/core/ncurses/ncurses.install
+++ /dev/null
@@ -1,9 +0,0 @@
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- echo ">> You can safely ignore any \"cannot open shared object\" errors you see above"
-}
-
-op=$1
-shift
-$op $*