summaryrefslogtreecommitdiffstats
path: root/abs/core/ncurses
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-06 01:06:40 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-06 01:06:40 (GMT)
commitfa050b437f10141db9c28b4f1327d27aa851d944 (patch)
treed46b04d9f727586bcd5db6de05f93030dcf03d1e /abs/core/ncurses
parent2e9de8e980bd65c44629c8e1cb84105d530ce560 (diff)
parent676db4cdf0ec3a29073ee4408b8a610b1b334bd3 (diff)
downloadlinhes_pkgbuild-fa050b437f10141db9c28b4f1327d27aa851d944.zip
linhes_pkgbuild-fa050b437f10141db9c28b4f1327d27aa851d944.tar.gz
linhes_pkgbuild-fa050b437f10141db9c28b4f1327d27aa851d944.tar.bz2
Merge branch 'testing' of knoppmyth.net:linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/ncurses')
-rw-r--r--abs/core/ncurses/PKGBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/abs/core/ncurses/PKGBUILD b/abs/core/ncurses/PKGBUILD
index c0fd425..017e900 100644
--- a/abs/core/ncurses/PKGBUILD
+++ b/abs/core/ncurses/PKGBUILD
@@ -1,26 +1,39 @@
-# $Id: PKGBUILD 19129 2008-11-15 00:00:47Z allan $
+# $Id: PKGBUILD 77821 2010-04-18 09:29:42Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=ncurses
pkgver=5.7
-pkgrel=2
+pkgrel=3
pkgdesc="System V Release 4.0 curses emulation library"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/ncurses/"
license=('MIT')
-groups=('base')
depends=('glibc')
source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
md5sums=('cce05daf61a64501ef6cd8da1f727ec6')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- ./configure --prefix=/usr --mandir=/usr/share/man \
+ cd ${srcdir}/
+ mkdir ncurses{,w}-build
+
+ cd ${srcdir}/ncursesw-build
+ ../${pkgname}-${pkgver}/configure --prefix=/usr --mandir=/usr/share/man \
--with-shared --with-normal --without-debug --without-ada \
--with-install-prefix=${pkgdir} --enable-widec
make || return 1
+
+ # libncurses.so.5 for external binary support
+ cd ${srcdir}/ncurses-build
+ [ $CARCH = "x86_64" ] && CONFIGFLAG="--with-chtype=long"
+ ../${pkgname}-${pkgver}/configure --prefix=/usr \
+ --with-shared --with-normal --without-debug --without-ada \
+ --with-install-prefix=${pkgdir} $CONFIGFLAG
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/ncursesw-build
make install
# move libraries needed for boot to /lib (we call tput in initscripts)
@@ -47,12 +60,8 @@ build() {
ln -sf libncursesw.a ${pkgdir}/usr/lib/libcursesw.a
ln -sf libncurses.a ${pkgdir}/usr/lib/libcurses.a
- # Install libncurses.so.5 for external binary support
- ./configure --prefix=/usr \
- --with-shared --with-normal --without-debug --without-ada \
- --with-install-prefix=${pkgdir}
- make || return 1
-
+ # non-widec compatibility library
+ cd ${srcdir}/ncurses-build
install -Dm755 lib/libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.${pkgver}
ln -sf libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.5