summaryrefslogtreecommitdiffstats
path: root/abs/core/net-tools
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 17:45:19 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 17:45:19 (GMT)
commit80d1276c4aab094c21ca671b71e5e3cddadefd58 (patch)
treed0a8e94b9cbfc407a5ee36bbfd6af15d6d063f55 /abs/core/net-tools
parent89ff735fa81051c94f7faeef86049d86aa2d4af7 (diff)
downloadlinhes_pkgbuild-80d1276c4aab094c21ca671b71e5e3cddadefd58.zip
linhes_pkgbuild-80d1276c4aab094c21ca671b71e5e3cddadefd58.tar.gz
linhes_pkgbuild-80d1276c4aab094c21ca671b71e5e3cddadefd58.tar.bz2
net-tools 1.60
Diffstat (limited to 'abs/core/net-tools')
-rw-r--r--abs/core/net-tools/PKGBUILD61
-rw-r--r--abs/core/net-tools/net-tools-1.60-miiioctl.patch14
-rw-r--r--abs/core/net-tools/net-tools.install12
-rw-r--r--abs/core/net-tools/net-tools.patch22
-rw-r--r--abs/core/net-tools/nisdomainname.conf.d3
5 files changed, 53 insertions, 59 deletions
diff --git a/abs/core/net-tools/PKGBUILD b/abs/core/net-tools/PKGBUILD
index da2a710..605620a 100644
--- a/abs/core/net-tools/PKGBUILD
+++ b/abs/core/net-tools/PKGBUILD
@@ -1,36 +1,43 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: judd <jvinet@zeroflux.org>
+# $Id: PKGBUILD 142384 2011-11-08 22:05:28Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
pkgname=net-tools
-pkgver=1.60
-pkgrel=22
+pkgver=1.60.20110819cvs
+pkgrel=3
pkgdesc="Configuration tools for Linux networking"
arch=(i686 x86_64)
-license=('GPL')
+license=('GPL2')
url="http://www.tazenda.demon.co.uk/phil/net-tools"
-groups=('base')
depends=('glibc')
-backup=('etc/conf.d/nisdomainname')
-source=(http://www.tazenda.demon.co.uk/phil/$pkgname/$pkgname-$pkgver.tar.bz2
- net-tools.patch gcc340.patch net-tools-1.60-2.6-compilefix.patch
- net-tools-1.60-miiioctl.patch nisdomainname.conf.d
- net-tools-1.60-nameif.patch
+
+# http://www.tazenda.demon.co.uk/phil/$pkgname/$pkgname-$pkgver.tar.bz2
+# use cvs checkout instead
+source=(ftp://ftp.archlinux.org/other/net-tools/net-tools-1.60.20110819cvs.tar.bz2
+ net-tools-1.60-miiioctl.patch
net-tools-1.60-nameif_strncpy.patch)
-md5sums=('888774accab40217dde927e21979c165' '7ef8d0c6818faa0fdeea94970a20e3fb'
- 'b52d899cba9956bb0055150506f41ac1' '51de6eabe2d6d6dc860f72c41cee636b'
- 'c16109863bc63f3dad4ef35305a340bb' 'af3eef5d4837939f7858eec692aa4671'
- '29a32617382fab1735acba4d920f1fcd' 'e66466b9304dac85eb42b32f1ec3b284')
+options=(!makeflags)
+install=net-tools.install
+sha1sums=('02946449191ff279f9f0f7fd7bc65ae21059a2bf'
+ '654a96bc6575efb4a2e04b49de45d448d240eb6e'
+ '7888000d8fe867e58b5b00fe2bcf6c3041d716b4')
build() {
- cd $startdir/src/$pkgname-$pkgver
- export MAKEFLAGS="-j1"
- patch -Np1 -i ../net-tools.patch || return 1
- patch -Np1 -i ../net-tools-1.60-2.6-compilefix.patch || return 1
- patch -Np1 -i ../net-tools-1.60-miiioctl.patch || return 1
- patch -Np1 -i ../gcc340.patch || return 1
- patch -Np1 -i ${startdir}/src/net-tools-1.60-nameif.patch || return 1
- patch -Np1 -i ${startdir}/src/net-tools-1.60-nameif_strncpy.patch || return 1
- yes "" | make || return 1
- make BASEDIR=$startdir/pkg update
- install -D -m644 ../nisdomainname.conf.d \
- $startdir/pkg/etc/conf.d/nisdomainname
+ cd $srcdir/$pkgname-$pkgver
+ patch -Np1 -i ../net-tools-1.60-miiioctl.patch
+ patch -Np1 -i ${srcdir}/net-tools-1.60-nameif_strncpy.patch
+ yes "" | make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make BASEDIR=$pkgdir update
+
+ # the following is provided by yp-tools
+ rm "${pkgdir}"/bin/{nis,yp}domainname
+ rm "${pkgdir}"/usr/share/man/man1/{nis,yp}domainname.1
+
+ # hostname is provided by inetutils
+ rm "${pkgdir}"/bin/{hostname,dnsdomainname,domainname}
+ rm -rf "${pkgdir}"/usr/share/man/man1
}
diff --git a/abs/core/net-tools/net-tools-1.60-miiioctl.patch b/abs/core/net-tools/net-tools-1.60-miiioctl.patch
index 4859273..6c7f069 100644
--- a/abs/core/net-tools/net-tools-1.60-miiioctl.patch
+++ b/abs/core/net-tools/net-tools-1.60-miiioctl.patch
@@ -1,17 +1,17 @@
---- net-tools-1.60/include/mii.h.bar Tue Jul 31 11:49:39 2001
-+++ net-tools-1.60/include/mii.h Tue Jul 31 11:49:33 2001
-@@ -11,11 +11,9 @@
-
+--- net-tools-1.60.20110819cvs/include/mii.h 2011-08-19 10:14:00.743873299 +0200
++++ net-tools-1.60.20110819cvs/include/mii.h.new 2011-08-19 10:28:26.500524160 +0200
+@@ -14,11 +14,9 @@
/* network interface ioctl's for MII commands */
#ifndef SIOCGMIIPHY
+ #warning "SIOCGMIIPHY is not defined by your kernel source"
-#define SIOCGMIIPHY (SIOCDEVPRIVATE) /* Read from current PHY */
-#define SIOCGMIIREG (SIOCDEVPRIVATE+1) /* Read any PHY register */
-#define SIOCSMIIREG (SIOCDEVPRIVATE+2) /* Write any PHY register */
-#define SIOCGPARAMS (SIOCDEVPRIVATE+3) /* Read operational parameters */
-#define SIOCSPARAMS (SIOCDEVPRIVATE+4) /* Set operational parameters */
-+#define SIOCGMIIPHY 0x8947 /* Read from current PHY */
-+#define SIOCGMIIREG 0x8948 /* Read any PHY register */
-+#define SIOCSMIIREG 0x8949 /* Write any PHY register */
++#define SIOCGMIIPHY 0x8947 /* Read from current PHY */
++#define SIOCGMIIREG 0x8948 /* Read any PHY register */
++#define SIOCSMIIREG 0x8949 /* Write any PHY register */
#endif
#include <linux/types.h>
diff --git a/abs/core/net-tools/net-tools.install b/abs/core/net-tools/net-tools.install
new file mode 100644
index 0000000..9eee9e5
--- /dev/null
+++ b/abs/core/net-tools/net-tools.install
@@ -0,0 +1,12 @@
+post_upgrade() {
+ if [ "$(vercmp $2 1.60-16)" -lt 0 ]; then
+ echo "hostname and {,yp,nis}domainname has moved:"
+ echo "----------"
+ echo "hostname is now in coreutils"
+ echo "domainname is now in yp-tools"
+ echo "their functionality might have changed slightly"
+ echo ""
+ echo "dnsdomainname remains in net-tools"
+ echo "----------"
+ fi
+}
diff --git a/abs/core/net-tools/net-tools.patch b/abs/core/net-tools/net-tools.patch
index 87e062e..8af2d21 100644
--- a/abs/core/net-tools/net-tools.patch
+++ b/abs/core/net-tools/net-tools.patch
@@ -1,25 +1,3 @@
-diff -Naur net-tools-1.60-orig/config.in net-tools-1.60/config.in
---- net-tools-1.60-orig/config.in 2000-05-21 07:32:12.000000000 -0700
-+++ net-tools-1.60/config.in 2004-05-31 12:36:00.000000000 -0700
-@@ -49,7 +49,7 @@
- *
- bool 'UNIX protocol family' HAVE_AFUNIX y
- bool 'INET (TCP/IP) protocol family' HAVE_AFINET y
--bool 'INET6 (IPv6) protocol family' HAVE_AFINET6 n
-+bool 'INET6 (IPv6) protocol family' HAVE_AFINET6 y
- bool 'Novell IPX/SPX protocol family' HAVE_AFIPX y
- bool 'Appletalk DDP protocol family' HAVE_AFATALK y
- bool 'AX25 (packet radio) protocol family' HAVE_AFAX25 y
-@@ -86,6 +86,6 @@
- *
- * Other Features.
- *
--bool 'IP Masquerading support' HAVE_FW_MASQUERADE n
--bool 'Build iptunnel and ipmaddr' HAVE_IP_TOOLS n
--bool 'Build mii-tool' HAVE_MII n
-+bool 'IP Masquerading support' HAVE_FW_MASQUERADE y
-+bool 'Build iptunnel and ipmaddr' HAVE_IP_TOOLS y
-+bool 'Build mii-tool' HAVE_MII y
diff -Naur net-tools-1.60-orig/mii-tool.c net-tools-1.60/mii-tool.c
--- net-tools-1.60-orig/mii-tool.c 2000-05-21 07:31:17.000000000 -0700
+++ net-tools-1.60/mii-tool.c 2004-05-31 12:35:21.000000000 -0700
diff --git a/abs/core/net-tools/nisdomainname.conf.d b/abs/core/net-tools/nisdomainname.conf.d
deleted file mode 100644
index 6033ecf..0000000
--- a/abs/core/net-tools/nisdomainname.conf.d
+++ /dev/null
@@ -1,3 +0,0 @@
-# Set your NIS domain name here
-NISDOMAINNAME=""
-