summaryrefslogtreecommitdiffstats
path: root/abs/core/nfsidmap
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/nfsidmap
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/nfsidmap')
-rw-r--r--abs/core/nfsidmap/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/nfsidmap/PKGBUILD b/abs/core/nfsidmap/PKGBUILD
new file mode 100644
index 0000000..401c1e7
--- /dev/null
+++ b/abs/core/nfsidmap/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 13097 2008-09-25 22:11:54Z ronald $
+# Maintainer:
+# Contributor: Judd <jvinet@zeroflux.org>
+
+pkgname=nfsidmap
+pkgver=0.21
+pkgrel=2
+pkgdesc="Library to help mapping IDs, mainly for NFSv4"
+arch=('i686' 'x86_64')
+url="http://www.citi.umich.edu/projects/nfsv4/linux/"
+depends=('glibc' 'libldap')
+license=('custom:nfsidmap')
+options=(!libtool)
+source=(http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/libnfsidmap-$pkgver.tar.gz)
+md5sums=('56b05e30645353befbf73bd905270d4b')
+
+build() {
+ cd $srcdir/lib$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+
+ # install license
+ install -Dm644 COPYING \
+ $pkgdir/usr/share/licenses/nfsidmap/LICENSE || return 1
+}