summaryrefslogtreecommitdiffstats
path: root/abs/core/nfsidmap
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-13 02:16:56 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-13 02:16:56 (GMT)
commitcf739da3ef34e05a4994fe86e93090f1e4772822 (patch)
treef5f633d3c37b64a479dd42f61c867f24cb8820cf /abs/core/nfsidmap
parent8087452d95b71aed84bc9868a29b97572b332173 (diff)
downloadlinhes_pkgbuild-cf739da3ef34e05a4994fe86e93090f1e4772822.zip
linhes_pkgbuild-cf739da3ef34e05a4994fe86e93090f1e4772822.tar.gz
linhes_pkgbuild-cf739da3ef34e05a4994fe86e93090f1e4772822.tar.bz2
nfsidmap: up to latest
Diffstat (limited to 'abs/core/nfsidmap')
-rw-r--r--abs/core/nfsidmap/PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/abs/core/nfsidmap/PKGBUILD b/abs/core/nfsidmap/PKGBUILD
index 401c1e7..c275f12 100644
--- a/abs/core/nfsidmap/PKGBUILD
+++ b/abs/core/nfsidmap/PKGBUILD
@@ -1,26 +1,31 @@
-# $Id: PKGBUILD 13097 2008-09-25 22:11:54Z ronald $
+# $Id: PKGBUILD 52311 2009-09-17 07:29:57Z allan $
# Maintainer:
# Contributor: Judd <jvinet@zeroflux.org>
pkgname=nfsidmap
-pkgver=0.21
-pkgrel=2
+pkgver=0.23
+pkgrel=3
pkgdesc="Library to help mapping IDs, mainly for NFSv4"
arch=('i686' 'x86_64')
url="http://www.citi.umich.edu/projects/nfsv4/linux/"
-depends=('glibc' 'libldap')
+depends=('glibc' 'libldap>=2.4.18')
license=('custom:nfsidmap')
options=(!libtool)
source=(http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/libnfsidmap-$pkgver.tar.gz)
-md5sums=('56b05e30645353befbf73bd905270d4b')
+md5sums=('28f3ece648c1dc5d25e8d623d55f8bd6')
build() {
cd $srcdir/lib$pkgname-$pkgver
./configure --prefix=/usr --sysconfdir=/etc
make || return 1
+}
+package() {
+ cd $srcdir/lib$pkgname-$pkgver
make DESTDIR=$pkgdir install || return 1
-
+ # remove idmap manpage provided by nfs-utils!
+ rm $pkgdir/usr/share/man/man5/idmapd.conf.5 || return 1
# install license
install -Dm644 COPYING \
- $pkgdir/usr/share/licenses/nfsidmap/LICENSE || return 1
+ $pkgdir/usr/share/licenses/nfsidmap/LICENSE || return 1
}
+