summaryrefslogtreecommitdiffstats
path: root/abs/core/nvidia-173xx
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/nvidia-173xx
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/nvidia-173xx')
-rw-r--r--abs/core/nvidia-173xx/PKGBUILD22
-rw-r--r--abs/core/nvidia-173xx/nvidia.install4
2 files changed, 15 insertions, 11 deletions
diff --git a/abs/core/nvidia-173xx/PKGBUILD b/abs/core/nvidia-173xx/PKGBUILD
index 845e606..83d4b8d 100644
--- a/abs/core/nvidia-173xx/PKGBUILD
+++ b/abs/core/nvidia-173xx/PKGBUILD
@@ -1,22 +1,23 @@
-# $Id: PKGBUILD 69360 2010-02-20 11:24:15Z tpowa $
+# $Id: PKGBUILD 28363 2009-03-01 00:06:27Z pierre $
# Maintainer : Thomas Baechler <thomas@archlinux.org>
pkgname=nvidia-173xx
-pkgver=173.14.25
-_kernver='2.6.28-LinHES'
-
+pkgver=173.14.27
+_kernver='2.6.34-LinHES'
pkgrel=1
pkgdesc="NVIDIA drivers for kernel26, 173xx branch."
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && ARCH=x86
[ "$CARCH" = "x86_64" ] && ARCH=x86_64
url="http://www.nvidia.com/"
-depends=('kernel26>=2.6.28' 'kernel26<2.6.29' 'nvidia-173xx-utils')
-makedepends=('kernel-headers>=2.6.28' 'kernel-headers<2.6.29')
-conflicts=('nvidia' 'nvidia-173xx')
+depends=('kernel26>=2.6.34' 'kernel26<2.6.35' 'nvidia-173xx-utils')
+makedepends=('kernel26-headers>=2.6.34' 'kernel26-headers<2.6.35')
+conflicts=('nvidia-96xx' 'nvidia')
license=('custom')
install=nvidia.install
source=("http://download.nvidia.com/XFree86/Linux-$ARCH/${pkgver}/NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run")
+md5sums=('35a6531f71cd6b070f10be8ed11093d4')
+[ "$CARCH" = "x86_64" ] && md5sums=('269425dbc2d9d4ecdc54692281d6d738')
build() {
cd $srcdir
@@ -25,10 +26,13 @@ build() {
cd usr/src/nv/
ln -s Makefile.kbuild Makefile
make SYSSRC=/lib/modules/${_kernver}/build module || return 1
+}
+package() {
+ cd $srcdir/NVIDIA-Linux-$ARCH-${pkgver}-pkg0/usr/src/nv/
mkdir -p $pkgdir/lib/modules/${_kernver}/kernel/drivers/video/
install -m644 nvidia.ko $pkgdir/lib/modules/${_kernver}/kernel/drivers/video/
-
+ mkdir -p $pkgdir/etc/modprobe.d
+ echo "blacklist nouveau" >> $pkgdir/etc/modprobe.d/nouveau_blacklist.conf || return 1
sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" $startdir/nvidia.install
}
-md5sums=('397bac51f760505ea57e863c1db9c572')
diff --git a/abs/core/nvidia-173xx/nvidia.install b/abs/core/nvidia-173xx/nvidia.install
index ab86ea2..a7e09f9 100644
--- a/abs/core/nvidia-173xx/nvidia.install
+++ b/abs/core/nvidia-173xx/nvidia.install
@@ -1,5 +1,5 @@
post_install() {
- KERNEL_VERSION='2.6.28-LinHES'
+ KERNEL_VERSION='2.6.34-LinHES'
depmod $KERNEL_VERSION
}
@@ -9,6 +9,6 @@ post_upgrade() {
}
post_remove() {
- KERNEL_VERSION='2.6.28-LinHES'
+ KERNEL_VERSION='2.6.34-LinHES'
depmod $KERNEL_VERSION
}