summaryrefslogtreecommitdiffstats
path: root/abs/core/nvidia-304xx
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-09-30 20:23:36 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-09-30 20:23:36 (GMT)
commit5ed06b715d7479dd2cebee0f69084cbd396de063 (patch)
tree911d595f02a478c1d3bafea8ea7bb1de7abfb0b5 /abs/core/nvidia-304xx
parentd685308565e7fe194211b8c917c341be29ee7bcf (diff)
downloadlinhes_pkgbuild-5ed06b715d7479dd2cebee0f69084cbd396de063.zip
linhes_pkgbuild-5ed06b715d7479dd2cebee0f69084cbd396de063.tar.gz
linhes_pkgbuild-5ed06b715d7479dd2cebee0f69084cbd396de063.tar.bz2
nvidia-304xx: rebuild for kernel
Diffstat (limited to 'abs/core/nvidia-304xx')
-rw-r--r--abs/core/nvidia-304xx/PKGBUILD22
-rw-r--r--abs/core/nvidia-304xx/linux-4.6.patch144
-rw-r--r--abs/core/nvidia-304xx/nvidia-304xx-dkms.install30
3 files changed, 157 insertions, 39 deletions
diff --git a/abs/core/nvidia-304xx/PKGBUILD b/abs/core/nvidia-304xx/PKGBUILD
index e3e3ec6..fd5952f 100644
--- a/abs/core/nvidia-304xx/PKGBUILD
+++ b/abs/core/nvidia-304xx/PKGBUILD
@@ -6,19 +6,20 @@ pkgbase=nvidia-304xx
pkgname=(nvidia-304xx nvidia-304xx-dkms)
pkgver=304.131
_extramodules=extramodules-4.4-ARCH
-pkgrel=9
+pkgrel=16
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
makedepends=('nvidia-304xx-libgl' "nvidia-304xx-utils=${pkgver}" 'linux' 'linux-headers>=4.4' 'linux-headers<4.5')
conflicts=('nvidia')
license=('custom')
options=('!strip')
-source=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
- "http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run"
- disable-mtrr.patch)
-sha512sums=('3e67c40648554dc49472081eee88ae982c3b235b3346e4d9e7fb5ae33ec5f10ed088da804ac7d8bd1565995df3861f12b3560030cd3a19339a2d35768b0a943e'
- '07e529e4e81c42b43861475029aa0f223f8f3d299be9ddfe820c583e26aae49223a9b0dfee6d66ab09c526554bb581e5f8cf755eda600cb9e0bdac7d5f4acb93'
- '54e8825e523f11706890e09e476498f3a30f75ce4e350ff2ff8a1e1c3af574d9ccfb8903543766b6863d94cdfbf46e68cd3d33380867dd976cafc8dd2dd78774')
+source=('disable-mtrr.patch' 'linux-4.6.patch')
+source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+sha512sums=('54e8825e523f11706890e09e476498f3a30f75ce4e350ff2ff8a1e1c3af574d9ccfb8903543766b6863d94cdfbf46e68cd3d33380867dd976cafc8dd2dd78774'
+ 'a240e354fcc8ad69982206b4291dfe0fa3660b410d0ffa7903c4fcdb2397254293bfa3160874f89327cfca85d78385260072008091990bc6640ea047e55c53ab')
+sha512sums_i686=('3e67c40648554dc49472081eee88ae982c3b235b3346e4d9e7fb5ae33ec5f10ed088da804ac7d8bd1565995df3861f12b3560030cd3a19339a2d35768b0a943e')
+sha512sums_x86_64=('07e529e4e81c42b43861475029aa0f223f8f3d299be9ddfe820c583e26aae49223a9b0dfee6d66ab09c526554bb581e5f8cf755eda600cb9e0bdac7d5f4acb93')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
@@ -31,6 +32,10 @@ prepare() {
# FS#47092
(cd kernel; patch -p1 --no-backup-if-mismatch -i "$srcdir"/disable-mtrr.patch)
+
+# patch -p1 --no-backup-if-mismatch -i ../linux-4.6.patch
+
+ cp -a kernel kernel-dkms
}
build() {
@@ -61,11 +66,10 @@ package_nvidia-304xx-dkms() {
optdepends=('linux-headers: Build the module for Arch kernel'
'linux-lts-headers: Build the module for LTS Arch kernel')
conflicts+=('nvidia-304xx')
- install=nvidia-304xx-dkms.install
cd ${_pkg}
make -C kernel clean
install -dm 755 "${pkgdir}"/usr/{lib/modprobe.d,src}
- cp -dr --no-preserve='ownership' kernel "${pkgdir}"/usr/src/nvidia-${pkgver}
+ cp -dr --no-preserve='ownership' kernel-dkms "${pkgdir}"/usr/src/nvidia-${pkgver}
echo 'blacklist nouveau' > "${pkgdir}"/usr/lib/modprobe.d/nvidia.conf
}
diff --git a/abs/core/nvidia-304xx/linux-4.6.patch b/abs/core/nvidia-304xx/linux-4.6.patch
new file mode 100644
index 0000000..5a55989
--- /dev/null
+++ b/abs/core/nvidia-304xx/linux-4.6.patch
@@ -0,0 +1,144 @@
+--- /dev/null
++++ b/kernel/nv-mm.h
+@@ -0,0 +1,55 @@
++/*******************************************************************************
++ Copyright (c) 2016 NVIDIA Corporation
++
++ Permission is hereby granted, free of charge, to any person obtaining a copy
++ of this software and associated documentation files (the "Software"), to
++ deal in the Software without restriction, including without limitation the
++ rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
++ sell copies of the Software, and to permit persons to whom the Software is
++ furnished to do so, subject to the following conditions:
++
++ The above copyright notice and this permission notice shall be
++ included in all copies or substantial portions of the Software.
++
++ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
++ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
++ DEALINGS IN THE SOFTWARE.
++
++*******************************************************************************/
++#ifndef __NV_MM_H__
++#define __NV_MM_H__
++
++/* get_user_pages_remote() was added by:
++ * 2016 Feb 12: 1e9877902dc7e11d2be038371c6fbf2dfcd469d7
++ *
++ * The very next commit (cde70140fed8429acf7a14e2e2cbd3e329036653)
++ * deprecated the 8-argument version of get_user_pages for the
++ * non-remote case (calling get_user_pages with current and current->mm).
++ *
++ * The guidelines are: call NV_GET_USER_PAGES_REMOTE if you need the 8-argument
++ * version that uses something other than current and current->mm. Use
++ * NV_GET_USER_PAGES if you are refering to current and current->mm.
++ *
++* Note that get_user_pages_remote() requires the caller to hold a reference on
++* the task_struct (if non-NULL) and the mm_struct. This will always be true
++* when using current and current->mm. If the kernel passes the driver a vma
++* via driver callback, the kernel holds a reference on vma->vm_mm over that
++* callback.
++ */
++
++#if defined(NV_GET_USER_PAGES_REMOTE_PRESENT)
++ #define NV_GET_USER_PAGES get_user_pages
++ #define NV_GET_USER_PAGES_REMOTE get_user_pages_remote
++#else
++ #define NV_GET_USER_PAGES(start, nr_pages, write, force, pages, vmas) \
++ get_user_pages(current, current->mm, start, nr_pages, write, force, pages, vmas)
++
++ #define NV_GET_USER_PAGES_REMOTE get_user_pages
++#endif
++
++
++#endif // __NV_MM_H__
+--- a/kernel/nv-mlock.c
++++ b/kernel/nv-mlock.c
+@@ -13,6 +13,7 @@
+
+ #include "os-interface.h"
+ #include "nv-linux.h"
++#include "nv-mm.h"
+
+ RM_STATUS NV_API_CALL nv_lock_user_pages(
+ nv_state_t *nv,
+@@ -49,7 +50,7 @@ RM_STATUS NV_API_CALL os_lock_user_pages(
+ }
+
+ down_read(&mm->mmap_sem);
+- ret = get_user_pages(current, mm, (unsigned long)address,
++ ret = NV_GET_USER_PAGES((unsigned long)address,
+ page_count, write, force, user_pages, NULL);
+ up_read(&mm->mmap_sem);
+ pinned = ret;
+@@ -62,7 +62,7 @@ RM_STATUS NV_API_CALL os_lock_user_pages(
+ else if (pinned < page_count)
+ {
+ for (i = 0; i < pinned; i++)
+- page_cache_release(user_pages[i]);
++ put_page(user_pages[i]);
+ os_free_mem(user_pages);
+ return RM_ERR_INVALID_ADDRESS;
+ }
+@@ -81,7 +81,7 @@ RM_STATUS NV_API_CALL os_lock_user_pages(
+ {
+ pci_unmap_page(dev, pte_array[j],
+ PAGE_SIZE, PCI_DMA_BIDIRECTIONAL);
+- page_cache_release(user_pages[j]);
++ put_page(user_pages[j]);
+ }
+ os_free_mem(user_pages);
+ return RM_ERR_OPERATING_SYSTEM;
+@@ -114,7 +114,7 @@ RM_STATUS NV_API_CALL os_unlock_user_pages(
+ PAGE_SIZE, PCI_DMA_BIDIRECTIONAL);
+ if (write)
+ set_page_dirty_lock(user_pages[i]);
+- page_cache_release(user_pages[i]);
++ put_page(user_pages[i]);
+ }
+
+ os_free_mem(user_pages);
+diff --git a/kernel/conftest.sh.orig b/kernel/conftest.sh
+index d01488b..308ea8a 100755
+--- a/kernel/conftest.sh
++++ b/kernel/conftest.sh
+@@ -1525,6 +1525,23 @@ compile_test() {
+
+ compile_check_conftest "$CODE" "NV_NODE_END_PFN_PRESENT" "" "functions"
+ ;;
++
++ get_user_pages_remote)
++ #
++ # Determine if the function get_user_pages_remote() is
++ # present.
++ #
++ # get_user_pages_remote() was added by:
++ # 2016 Feb 12: 1e9877902dc7e11d2be038371c6fbf2dfcd469d7
++ #
++ CODE="
++ #include <linux/mm.h>
++ int conftest_get_user_pages_remote(void) {
++ get_user_pages_remote();
++ }"
++
++ compile_check_conftest "$CODE" "NV_GET_USER_PAGES_REMOTE_PRESENT" "" "functions"
++ ;;
+ esac
+ }
+
+--- a/kernel/Makefile.kbuild
++++ b/kernel/Makefile.kbuild
+@@ -187,7 +187,8 @@ COMPILE_TESTS = \
+ drm_pci_set_busid \
+ write_cr4 \
+ for_each_online_node \
+- node_end_pfn
++ node_end_pfn \
++ get_user_pages_remote
+
+ #
+ # CFLAGS dependent on the type of builds (e.g. single/muliple module, debug)
diff --git a/abs/core/nvidia-304xx/nvidia-304xx-dkms.install b/abs/core/nvidia-304xx/nvidia-304xx-dkms.install
deleted file mode 100644
index 3d9b74d..0000000
--- a/abs/core/nvidia-304xx/nvidia-304xx-dkms.install
+++ /dev/null
@@ -1,30 +0,0 @@
-#/bin/sh
-
-# arg 1: the new package version
-post_install() {
- dkms add nvidia/${1%-*}
- cat << EOF
-==> To build and install your modules run: dkms install nvidia/${1%-*}
-==> To do this automatically at startup run: systemctl enable dkms.service
-EOF
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-pre_upgrade() {
- pre_remove "$2"
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install "$1"
-}
-
-# arg 1: the old package version
-pre_remove() {
- # Remove modules using dkms
- [ -n "${1%-*}" ] && dkms remove nvidia/${1%-*} --all &>/dev/null || true
-}
-
-# vim:set ts=2 sw=2 ft=sh et: