summaryrefslogtreecommitdiffstats
path: root/abs/core/nvidia-304xx
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-03-01 15:36:49 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-03-01 15:36:49 (GMT)
commitcb5ff89483c27fb6db94dcff9c1ffb0985c3e13e (patch)
tree4114403737c60be51e3fd5df586a1f7c48b63e58 /abs/core/nvidia-304xx
parent48122bf54f33fcf6e5324d181eefdcdc0a6680d1 (diff)
downloadlinhes_pkgbuild-cb5ff89483c27fb6db94dcff9c1ffb0985c3e13e.zip
linhes_pkgbuild-cb5ff89483c27fb6db94dcff9c1ffb0985c3e13e.tar.gz
linhes_pkgbuild-cb5ff89483c27fb6db94dcff9c1ffb0985c3e13e.tar.bz2
nvidia-304xx: rebuild for linux 4.4.3
Diffstat (limited to 'abs/core/nvidia-304xx')
-rw-r--r--abs/core/nvidia-304xx/PKGBUILD11
-rw-r--r--abs/core/nvidia-304xx/disable-mtrr.patch24
2 files changed, 32 insertions, 3 deletions
diff --git a/abs/core/nvidia-304xx/PKGBUILD b/abs/core/nvidia-304xx/PKGBUILD
index d855134..47fe1b6 100644
--- a/abs/core/nvidia-304xx/PKGBUILD
+++ b/abs/core/nvidia-304xx/PKGBUILD
@@ -6,7 +6,7 @@ pkgbase=nvidia-304xx
pkgname=(nvidia-304xx nvidia-304xx-dkms)
pkgver=304.131
_extramodules=extramodules-4.4-ARCH
-pkgrel=4
+pkgrel=7
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
makedepends=('nvidia-304xx-libgl' "nvidia-304xx-utils=${pkgver}" 'linux' 'linux-headers>=4.4' 'linux-headers<4.5')
@@ -14,9 +14,11 @@ conflicts=('nvidia')
license=('custom')
options=('!strip')
source=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
- "http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+ "http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run"
+ disable-mtrr.patch)
sha512sums=('3e67c40648554dc49472081eee88ae982c3b235b3346e4d9e7fb5ae33ec5f10ed088da804ac7d8bd1565995df3861f12b3560030cd3a19339a2d35768b0a943e'
- '07e529e4e81c42b43861475029aa0f223f8f3d299be9ddfe820c583e26aae49223a9b0dfee6d66ab09c526554bb581e5f8cf755eda600cb9e0bdac7d5f4acb93')
+ '07e529e4e81c42b43861475029aa0f223f8f3d299be9ddfe820c583e26aae49223a9b0dfee6d66ab09c526554bb581e5f8cf755eda600cb9e0bdac7d5f4acb93'
+ '54e8825e523f11706890e09e476498f3a30f75ce4e350ff2ff8a1e1c3af574d9ccfb8903543766b6863d94cdfbf46e68cd3d33380867dd976cafc8dd2dd78774')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
@@ -26,6 +28,9 @@ prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
# patches here
+
+ # FS#47092
+ (cd kernel; patch -p1 --no-backup-if-mismatch -i "$srcdir"/disable-mtrr.patch)
}
build() {
diff --git a/abs/core/nvidia-304xx/disable-mtrr.patch b/abs/core/nvidia-304xx/disable-mtrr.patch
new file mode 100644
index 0000000..9be9e2c
--- /dev/null
+++ b/abs/core/nvidia-304xx/disable-mtrr.patch
@@ -0,0 +1,24 @@
+Author: Luca Boccassi <luca.boccassi@gmail.com>
+Description: Disable MTRR on kernel >= 4.3
+ From kernel 4.3 and newer (commit 2baa891e42d84) mtrr_add and mtrr_del are no
+ longer exported. The Nvidia kernel shim still uses it as of 304.131, causing
+ the module to error out when loading. Disable MTRR if running on 4.3 or greater
+ until upstream fixes it.
+--- a/nv-linux.h
++++ b/nv-linux.h
+@@ -256,6 +256,15 @@
+ #include <linux/seq_file.h>
+ #endif
+
++/*
++ * As of version 304.131, os-agp.c and os-mtrr.c still use deprecated
++ * kernel APIs for mtrr which are no longer exported since 4.3, causing
++ * the module to error out when loaded.
++ */
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,3,0)
++#undef CONFIG_MTRR
++#endif
++
+ #if !defined(NV_VMWARE) && defined(CONFIG_MTRR)
+ #include <asm/mtrr.h>
+ #endif