summaryrefslogtreecommitdiffstats
path: root/abs/core/nvidia-340xx
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-06-07 20:49:26 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-06-07 20:49:26 (GMT)
commit092fbc5206087dd046ba1619fa7f053d712b825f (patch)
treee5ae9e390a959a423a98605cc216937616e3c18a /abs/core/nvidia-340xx
parent1102bb0c5ca441eff2cdfdb07ae9f7e7678e7740 (diff)
downloadlinhes_pkgbuild-092fbc5206087dd046ba1619fa7f053d712b825f.zip
linhes_pkgbuild-092fbc5206087dd046ba1619fa7f053d712b825f.tar.gz
linhes_pkgbuild-092fbc5206087dd046ba1619fa7f053d712b825f.tar.bz2
nvidia-340xx: rebuild for linux 4.9.31
Diffstat (limited to 'abs/core/nvidia-340xx')
-rw-r--r--abs/core/nvidia-340xx/4.11.0_kernel.patch112
-rw-r--r--abs/core/nvidia-340xx/PKGBUILD10
2 files changed, 118 insertions, 4 deletions
diff --git a/abs/core/nvidia-340xx/4.11.0_kernel.patch b/abs/core/nvidia-340xx/4.11.0_kernel.patch
new file mode 100644
index 0000000..5ee3e4f
--- /dev/null
+++ b/abs/core/nvidia-340xx/4.11.0_kernel.patch
@@ -0,0 +1,112 @@
+--- a/kernel/nv-drm.c
++++ b/kernel/nv-drm.c
+@@ -22,6 +22,8 @@
+ #include <drm/drm_gem.h>
+ #endif
+
++#include <linux/version.h>
++
+ extern nv_linux_state_t *nv_linux_devices;
+
+ struct nv_gem_object {
+@@ -48,7 +50,11 @@
+ return -ENODEV;
+ }
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+ static int nv_drm_unload(
++#else
++static void nv_drm_unload(
++#endif
+ struct drm_device *dev
+ )
+ {
+@@ -60,11 +66,19 @@
+ {
+ BUG_ON(nvl->drm != dev);
+ nvl->drm = NULL;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+ return 0;
++#else
++ return;
++#endif
+ }
+ }
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+ return -ENODEV;
++#else
++ return;
++#endif
+ }
+
+ static void nv_gem_free(
+
+--- a/kernel/uvm/nvidia_uvm_linux.h
++++ b/kernel/uvm/nvidia_uvm_linux.h
+@@ -124,6 +124,9 @@
+ #include <linux/delay.h> /* mdelay, udelay */
+
+ #include <linux/sched.h> /* suser(), capable() replacement */
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++#include <linux/sched/signal.h>
++#endif
+ #include <linux/moduleparam.h> /* module_param() */
+ #if !defined(NV_VMWARE)
+ #include <asm/tlbflush.h> /* flush_tlb(), flush_tlb_all() */
+@@ -362,6 +365,7 @@
+ void address_space_init_once(struct address_space *mapping);
+ #endif
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+ #if !defined(NV_FATAL_SIGNAL_PENDING_PRESENT)
+ static inline int __fatal_signal_pending(struct task_struct *p)
+ {
+@@ -372,6 +376,7 @@
+ {
+ return signal_pending(p) && __fatal_signal_pending(p);
+ }
++#endif
+ #endif
+
+ //
+
+--- a/kernel/uvm/nvidia_uvm_lite.c
++++ b/kernel/uvm/nvidia_uvm_lite.c
+@@ -818,7 +818,11 @@
+ }
+
+ #if defined(NV_VM_OPERATIONS_STRUCT_HAS_FAULT)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++int _fault(struct vm_fault *vmf)
++#else
+ int _fault(struct vm_area_struct *vma, struct vm_fault *vmf)
++#endif
+ {
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
+ unsigned long vaddr = (unsigned long)vmf->virtual_address;
+@@ -828,7 +832,11 @@
+ struct page *page = NULL;
+ int retval;
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++ retval = _fault_common(NULL, vaddr, &page, vmf->flags);
++#else
+ retval = _fault_common(vma, vaddr, &page, vmf->flags);
++#endif
+
+ vmf->page = page;
+
+@@ -866,7 +874,11 @@
+ // it's dealing with anonymous mapping (see handle_pte_fault).
+ //
+ #if defined(NV_VM_OPERATIONS_STRUCT_HAS_FAULT)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++int _sigbus_fault(struct vm_fault *vmf)
++#else
+ int _sigbus_fault(struct vm_area_struct *vma, struct vm_fault *vmf)
++#endif
+ {
+ vmf->page = NULL;
+ return VM_FAULT_SIGBUS;
+
diff --git a/abs/core/nvidia-340xx/PKGBUILD b/abs/core/nvidia-340xx/PKGBUILD
index 5f404fa..c2b6f16 100644
--- a/abs/core/nvidia-340xx/PKGBUILD
+++ b/abs/core/nvidia-340xx/PKGBUILD
@@ -6,18 +6,19 @@ pkgbase=nvidia-340xx
pkgname=(nvidia-340xx nvidia-340xx-dkms)
pkgver=340.102
_extramodules=extramodules-4.9-ARCH
-pkgrel=6
+pkgrel=7
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
makedepends=("nvidia-340xx-utils=${pkgver}" 'linux' 'linux-headers>=4.9' 'linux-headers<4.10')
conflicts=('nvidia')
license=('custom')
options=(!strip)
-source=('fs52243.patch' '4.10.0_kernel.patch')
+source=('fs52243.patch' '4.10.0_kernel.patch' '4.11.0_kernel.patch')
source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
sha512sums=('de4f697d64f8e73c4aadec1a407884a6bc459c0020d4bfd19740fe4177a60bb801fe8a74ef6f7fa2e89c6cd648ea4daf152799ae344a145c06480a6eef0c5bca'
- '88a2b448c1e8445dc43820328e86d8f20eb7e3cb5774e704cd44191a9fa26064264510c1adc9ea938fa2c92075496f3a27bd52ae6e6f4ec5fa6d4a829dd961e8')
+ '88a2b448c1e8445dc43820328e86d8f20eb7e3cb5774e704cd44191a9fa26064264510c1adc9ea938fa2c92075496f3a27bd52ae6e6f4ec5fa6d4a829dd961e8'
+ '48eb48dfd118a5d76d0e01c3bb5aedb7e6ec153a40680c0ebd6842c74fe1dda49e1cc8dc2b2493b7355de47d3013c578a13c254c5bb3eecdbfcf8f4ebc7c7c34')
sha512sums_i686=('bea700c925a6044fcded40324bb389c5fa1aadc40831f685a76e7b0ded11161f492960950c201467e564d157dcbe0c330d13a2014f51d0073002c5a262a6f0ca')
sha512sums_x86_64=('2a29e6418244ea384e4237d74057bd8e56247b1c503cf623dea34a3b1065d8783879aa7e6a802dd31f0a10cf81cfcab2a1b1a8269b97996f15fa1838c0a3a44b')
@@ -30,7 +31,8 @@ prepare() {
# patches here
patch -Np0 < "${srcdir}"/fs52243.patch
-# patch -Np1 < "${srcdir}"/4.10.0_kernel.patch
+ patch -Np1 < "${srcdir}"/4.10.0_kernel.patch
+ patch -Np1 < "${srcdir}"/4.11.0_kernel.patch
cp -a kernel kernel-dkms
}