summaryrefslogtreecommitdiffstats
path: root/abs/core/nvidia-340xx
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-11-22 17:45:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-11-22 17:45:12 (GMT)
commitbe0043037d6f113d4b82d8884daa745b4db15742 (patch)
tree171fb39301960056864a57f5f838fa9ed6013425 /abs/core/nvidia-340xx
parent9e9f8830d7f654e2a7f5ba4087b71eab3a67c2b3 (diff)
downloadlinhes_pkgbuild-be0043037d6f113d4b82d8884daa745b4db15742.zip
linhes_pkgbuild-be0043037d6f113d4b82d8884daa745b4db15742.tar.gz
linhes_pkgbuild-be0043037d6f113d4b82d8884daa745b4db15742.tar.bz2
nvidia-340xx, nvidia-340xx-utils: update to 340.104
Diffstat (limited to 'abs/core/nvidia-340xx')
-rw-r--r--abs/core/nvidia-340xx/4.10.0_kernel.patch131
-rw-r--r--abs/core/nvidia-340xx/4.11.0_kernel.patch112
-rw-r--r--abs/core/nvidia-340xx/PKGBUILD59
-rw-r--r--abs/core/nvidia-340xx/fs52243.patch14
-rw-r--r--abs/core/nvidia-340xx/kernel-4.11.patch38
-rw-r--r--abs/core/nvidia-340xx/kernel-4.14.patch29
-rw-r--r--abs/core/nvidia-340xx/nvidia-340xx.install13
7 files changed, 95 insertions, 301 deletions
diff --git a/abs/core/nvidia-340xx/4.10.0_kernel.patch b/abs/core/nvidia-340xx/4.10.0_kernel.patch
deleted file mode 100644
index f4297b1..0000000
--- a/abs/core/nvidia-340xx/4.10.0_kernel.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-From 983a2ca221a371e08bb5ad11758a729cfa5aa88c Mon Sep 17 00:00:00 2001
-From: Alberto Milone <alberto.milone@canonical.com>
-Date: Wed, 15 Feb 2017 17:05:55 +0100
-Subject: [PATCH 1/1] Add support for Linux 4.10
-
----
- nv-linux.h | 7 +++++++
- nv-pat.c | 40 ++++++++++++++++++++++++++++++++++++++++
- uvm/nvidia_uvm_lite.c | 4 ++++
- 3 files changed, 51 insertions(+)
-
-diff --git a/kernel/nv-linux.h b/kernel/nv-linux.h
-index e7068e3..2d62492 100644
---- a/kernel/nv-linux.h
-+++ b/kernel/nv-linux.h
-@@ -2082,6 +2082,8 @@ static inline NvU64 nv_node_end_pfn(int nid)
- * 2016 Dec 14:5b56d49fc31dbb0487e14ead790fc81ca9fb2c99
- */
-
-+#include <linux/version.h>
-+
- #if defined(NV_GET_USER_PAGES_REMOTE_PRESENT)
- #if defined(NV_GET_USER_PAGES_HAS_WRITE_AND_FORCE_ARGS)
- #define NV_GET_USER_PAGES get_user_pages
-@@ -2129,8 +2131,13 @@ static inline NvU64 nv_node_end_pfn(int nid)
-
- #else
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
- return get_user_pages_remote(tsk, mm, start, nr_pages, flags,
- pages, vmas);
-+#else
-+ return get_user_pages_remote(tsk, mm, start, nr_pages, flags,
-+ pages, vmas, NULL);
-+#endif
-
- #endif
-
-diff --git a/kernel/nv-pat.c b/kernel/nv-pat.c
-index a725533..cec6f3f 100644
---- a/kernel/nv-pat.c
-+++ b/kernel/nv-pat.c
-@@ -203,6 +203,7 @@ void nv_disable_pat_support(void)
- }
-
- #if defined(NV_ENABLE_PAT_SUPPORT) && defined(NV_ENABLE_HOTPLUG_CPU)
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
- static int
- nvidia_cpu_callback(struct notifier_block *nfb, unsigned long action, void *hcpu)
- {
-@@ -234,6 +235,34 @@ static struct notifier_block nv_hotcpu_nfb = {
- .notifier_call = nvidia_cpu_callback,
- .priority = 0
- };
-+#else
-+static int nvidia_cpu_online(unsigned int hcpu)
-+{
-+ unsigned int cpu = get_cpu();
-+ if (cpu == hcpu)
-+ nv_setup_pat_entries(NULL);
-+ else
-+ NV_SMP_CALL_FUNCTION(nv_setup_pat_entries, (void *)(long int)hcpu, 1);
-+
-+ put_cpu();
-+
-+ return 0;
-+}
-+
-+static int nvidia_cpu_down_prep(unsigned int hcpu)
-+{
-+ unsigned int cpu = get_cpu();
-+ if (cpu == hcpu)
-+ nv_restore_pat_entries(NULL);
-+ else
-+ NV_SMP_CALL_FUNCTION(nv_restore_pat_entries, (void *)(long int)hcpu, 1);
-+
-+ put_cpu();
-+
-+ return 0;
-+}
-+#endif
-+
- #endif
-
- int nv_init_pat_support(nv_stack_t *sp)
-@@ -255,7 +284,14 @@ int nv_init_pat_support(nv_stack_t *sp)
- #if defined(NV_ENABLE_PAT_SUPPORT) && defined(NV_ENABLE_HOTPLUG_CPU)
- if (nv_pat_mode == NV_PAT_MODE_BUILTIN)
- {
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
- if (register_hotcpu_notifier(&nv_hotcpu_nfb) != 0)
-+#else
-+ if (cpuhp_setup_state(CPUHP_AP_ONLINE_DYN,
-+ "gpu/nvidia:online",
-+ nvidia_cpu_online,
-+ nvidia_cpu_down_prep) != 0)
-+#endif
- {
- nv_disable_pat_support();
- nv_printf(NV_DBG_ERRORS,
-@@ -280,7 +316,11 @@ void nv_teardown_pat_support(void)
- {
- nv_disable_pat_support();
- #if defined(NV_ENABLE_PAT_SUPPORT) && defined(NV_ENABLE_HOTPLUG_CPU)
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
- unregister_hotcpu_notifier(&nv_hotcpu_nfb);
-+#else
-+ cpuhp_remove_state_nocalls(CPUHP_AP_ONLINE_DYN);
-+#endif
- #endif
- }
- }
-diff --git a/kernel/uvm/nvidia_uvm_lite.c b/kernel/uvm/nvidia_uvm_lite.c
-index 9627f60..2158b45 100644
---- a/kernel/uvm/nvidia_uvm_lite.c
-+++ b/kernel/uvm/nvidia_uvm_lite.c
-@@ -820,7 +820,11 @@ done:
- #if defined(NV_VM_OPERATIONS_STRUCT_HAS_FAULT)
- int _fault(struct vm_area_struct *vma, struct vm_fault *vmf)
- {
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
- unsigned long vaddr = (unsigned long)vmf->virtual_address;
-+#else
-+ unsigned long vaddr = (unsigned long)vmf->address;
-+#endif
- struct page *page = NULL;
- int retval;
-
---
-2.7.4
-
diff --git a/abs/core/nvidia-340xx/4.11.0_kernel.patch b/abs/core/nvidia-340xx/4.11.0_kernel.patch
deleted file mode 100644
index 5ee3e4f..0000000
--- a/abs/core/nvidia-340xx/4.11.0_kernel.patch
+++ /dev/null
@@ -1,112 +0,0 @@
---- a/kernel/nv-drm.c
-+++ b/kernel/nv-drm.c
-@@ -22,6 +22,8 @@
- #include <drm/drm_gem.h>
- #endif
-
-+#include <linux/version.h>
-+
- extern nv_linux_state_t *nv_linux_devices;
-
- struct nv_gem_object {
-@@ -48,7 +50,11 @@
- return -ENODEV;
- }
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
- static int nv_drm_unload(
-+#else
-+static void nv_drm_unload(
-+#endif
- struct drm_device *dev
- )
- {
-@@ -60,11 +66,19 @@
- {
- BUG_ON(nvl->drm != dev);
- nvl->drm = NULL;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
- return 0;
-+#else
-+ return;
-+#endif
- }
- }
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
- return -ENODEV;
-+#else
-+ return;
-+#endif
- }
-
- static void nv_gem_free(
-
---- a/kernel/uvm/nvidia_uvm_linux.h
-+++ b/kernel/uvm/nvidia_uvm_linux.h
-@@ -124,6 +124,9 @@
- #include <linux/delay.h> /* mdelay, udelay */
-
- #include <linux/sched.h> /* suser(), capable() replacement */
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
-+#include <linux/sched/signal.h>
-+#endif
- #include <linux/moduleparam.h> /* module_param() */
- #if !defined(NV_VMWARE)
- #include <asm/tlbflush.h> /* flush_tlb(), flush_tlb_all() */
-@@ -362,6 +365,7 @@
- void address_space_init_once(struct address_space *mapping);
- #endif
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
- #if !defined(NV_FATAL_SIGNAL_PENDING_PRESENT)
- static inline int __fatal_signal_pending(struct task_struct *p)
- {
-@@ -372,6 +376,7 @@
- {
- return signal_pending(p) && __fatal_signal_pending(p);
- }
-+#endif
- #endif
-
- //
-
---- a/kernel/uvm/nvidia_uvm_lite.c
-+++ b/kernel/uvm/nvidia_uvm_lite.c
-@@ -818,7 +818,11 @@
- }
-
- #if defined(NV_VM_OPERATIONS_STRUCT_HAS_FAULT)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
-+int _fault(struct vm_fault *vmf)
-+#else
- int _fault(struct vm_area_struct *vma, struct vm_fault *vmf)
-+#endif
- {
- #if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
- unsigned long vaddr = (unsigned long)vmf->virtual_address;
-@@ -828,7 +832,11 @@
- struct page *page = NULL;
- int retval;
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
-+ retval = _fault_common(NULL, vaddr, &page, vmf->flags);
-+#else
- retval = _fault_common(vma, vaddr, &page, vmf->flags);
-+#endif
-
- vmf->page = page;
-
-@@ -866,7 +874,11 @@
- // it's dealing with anonymous mapping (see handle_pte_fault).
- //
- #if defined(NV_VM_OPERATIONS_STRUCT_HAS_FAULT)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
-+int _sigbus_fault(struct vm_fault *vmf)
-+#else
- int _sigbus_fault(struct vm_area_struct *vma, struct vm_fault *vmf)
-+#endif
- {
- vmf->page = NULL;
- return VM_FAULT_SIGBUS;
-
diff --git a/abs/core/nvidia-340xx/PKGBUILD b/abs/core/nvidia-340xx/PKGBUILD
index 2327a4e..bff3ae3 100644
--- a/abs/core/nvidia-340xx/PKGBUILD
+++ b/abs/core/nvidia-340xx/PKGBUILD
@@ -4,35 +4,31 @@
pkgbase=nvidia-340xx
pkgname=(nvidia-340xx nvidia-340xx-dkms)
-pkgver=340.102
+pkgver=340.104
_extramodules=extramodules-4.9-ARCH
-pkgrel=8
-arch=('i686' 'x86_64')
+pkgrel=7
+pkgdesc="NVIDIA drivers for linux, 340xx legacy branch"
+arch=('x86_64')
url="http://www.nvidia.com/"
makedepends=("nvidia-340xx-utils=${pkgver}" 'linux' 'linux-headers>=4.9' 'linux-headers<4.10')
conflicts=('nvidia')
license=('custom')
-options=(!strip)
-source=('fs52243.patch' '4.10.0_kernel.patch' '4.11.0_kernel.patch')
-source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
-source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha512sums=('de4f697d64f8e73c4aadec1a407884a6bc459c0020d4bfd19740fe4177a60bb801fe8a74ef6f7fa2e89c6cd648ea4daf152799ae344a145c06480a6eef0c5bca'
- '88a2b448c1e8445dc43820328e86d8f20eb7e3cb5774e704cd44191a9fa26064264510c1adc9ea938fa2c92075496f3a27bd52ae6e6f4ec5fa6d4a829dd961e8'
- '48eb48dfd118a5d76d0e01c3bb5aedb7e6ec153a40680c0ebd6842c74fe1dda49e1cc8dc2b2493b7355de47d3013c578a13c254c5bb3eecdbfcf8f4ebc7c7c34')
-sha512sums_i686=('bea700c925a6044fcded40324bb389c5fa1aadc40831f685a76e7b0ded11161f492960950c201467e564d157dcbe0c330d13a2014f51d0073002c5a262a6f0ca')
-sha512sums_x86_64=('2a29e6418244ea384e4237d74057bd8e56247b1c503cf623dea34a3b1065d8783879aa7e6a802dd31f0a10cf81cfcab2a1b1a8269b97996f15fa1838c0a3a44b')
+options=('!strip')
+source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run"
+ 'kernel-4.11.patch' 'kernel-4.14.patch')
+sha512sums=('e962494561728af5a911354bfb3560e414464f7858f30f9654eac5ca56175bc8498d1eee93a18248c63e9eee7d84807ef924fe9f53239644d7085b0f3502bf8c'
+ 'c25d90499e1deb26129a67dd7e953be8c1e31c5770e2b8b64d03af54cf1afec1a52636e74900f8ac468692207ab8a3765a12edd581142c4d2cfd2d6e66ac7ac2'
+ 'ccaa40e085d985ec4280003e36dd06e60958ed1408867379fd21a68a18d48aa4be311bf9ad1e804f7a7245c90be98e919d2ec30f45d290f1cdb19c866bdb8a8d')
-[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
-[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
+_pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
# patches here
- patch -Np0 < "${srcdir}"/fs52243.patch
- patch -Np1 < "${srcdir}"/4.10.0_kernel.patch
- patch -Np1 < "${srcdir}"/4.11.0_kernel.patch
+ patch -Np0 < "${srcdir}/kernel-4.11.patch"
+ patch -Np1 < "${srcdir}/kernel-4.14.patch"
cp -a kernel kernel-dkms
}
@@ -48,29 +44,30 @@ build() {
package_nvidia-340xx() {
pkgdesc="NVIDIA drivers for linux, 340xx legacy branch"
- depends=('linux>=4.9' 'linux<4.10' 'libgl' "nvidia-340xx-utils=${pkgver}")
- conflict+=('nvidia-340xx-dkms')
- install=nvidia-340xx.install
+ depends=('linux>=4.9' 'linux<4.10' "nvidia-340xx-utils=${pkgver}" 'libgl')
- install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
- "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
- install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
- "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
- gzip "${pkgdir}/usr/lib/modules/${_extramodules}/"*.ko
- install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
- echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
+ install -Dt "${pkgdir}/usr/lib/modules/${_extramodules}" -m644 \
+ "${srcdir}/${_pkg}/kernel"/{nvidia,uvm/nvidia-uvm}.ko
+
+ find "${pkgdir}" -name '*.ko' -exec gzip -n {} +
+
+ echo "blacklist nouveau" |
+ install -Dm644 /dev/stdin "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
}
package_nvidia-340xx-dkms() {
pkgdesc="NVIDIA driver sources for linux, 340xx legacy branch"
- depends=('dkms' "nvidia-340xx-utils=$pkgver")
+ depends=('dkms' "nvidia-340xx-utils=$pkgver" 'libgl')
optdepends=('linux-headers: Build the module for Arch kernel'
'linux-lts-headers: Build the module for LTS Arch kernel')
conflicts+=('nvidia-340xx')
cd ${_pkg}
- install -dm 755 "${pkgdir}"/usr/{lib/modprobe.d,src}
- cp -dr --no-preserve='ownership' kernel-dkms "${pkgdir}"/usr/src/nvidia-${pkgver}
- echo 'blacklist nouveau' > "${pkgdir}"/usr/lib/modprobe.d/nvidia.conf
+
+ install -dm 755 "${pkgdir}"/usr/src
+ cp -dr --no-preserve='ownership' kernel-dkms "${pkgdir}/usr/src/nvidia-${pkgver}"
cat "${pkgdir}"/usr/src/nvidia-${pkgver}/uvm/dkms.conf.fragment >> "${pkgdir}"/usr/src/nvidia-${pkgver}/dkms.conf
+
+ echo "blacklist nouveau" |
+ install -Dm644 /dev/stdin "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
}
diff --git a/abs/core/nvidia-340xx/fs52243.patch b/abs/core/nvidia-340xx/fs52243.patch
deleted file mode 100644
index b6dc35a..0000000
--- a/abs/core/nvidia-340xx/fs52243.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- kernel/nv-drm.c 2016-12-15 12:41:26.000000000 +0100
-+++ kernel/nv-drm.c 2016-12-15 12:58:48.000000000 +0100
-@@ -115,7 +115,11 @@
- };
-
- static struct drm_driver nv_drm_driver = {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
-+ .driver_features = DRIVER_GEM | DRIVER_PRIME | DRIVER_LEGACY,
-+#else
- .driver_features = DRIVER_GEM | DRIVER_PRIME,
-+#endif
- .load = nv_drm_load,
- .unload = nv_drm_unload,
- .fops = &nv_drm_fops,
diff --git a/abs/core/nvidia-340xx/kernel-4.11.patch b/abs/core/nvidia-340xx/kernel-4.11.patch
new file mode 100644
index 0000000..b2b3a7a
--- /dev/null
+++ b/abs/core/nvidia-340xx/kernel-4.11.patch
@@ -0,0 +1,38 @@
+--- kernel/uvm/nvidia_uvm_lite.c 2017-09-27 13:50:46.334075042 +0200
++++ kernel/uvm/nvidia_uvm_lite.c 2017-09-27 13:56:06.358041280 +0200
+@@ -818,7 +818,11 @@
+ }
+
+ #if defined(NV_VM_OPERATIONS_STRUCT_HAS_FAULT)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+ int _fault(struct vm_area_struct *vma, struct vm_fault *vmf)
++#else
++int _fault(struct vm_fault *vmf)
++#endif
+ {
+ #if defined(NV_VM_FAULT_HAS_ADDRESS)
+ unsigned long vaddr = vmf->address;
+@@ -828,7 +832,11 @@
+ struct page *page = NULL;
+ int retval;
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+ retval = _fault_common(vma, vaddr, &page, vmf->flags);
++#else
++ retval = _fault_common(NULL, vaddr, &page, vmf->flags);
++#endif
+
+ vmf->page = page;
+
+@@ -866,7 +874,11 @@
+ // it's dealing with anonymous mapping (see handle_pte_fault).
+ //
+ #if defined(NV_VM_OPERATIONS_STRUCT_HAS_FAULT)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+ int _sigbus_fault(struct vm_area_struct *vma, struct vm_fault *vmf)
++#else
++int _sigbus_fault(struct vm_fault *vmf)
++#endif
+ {
+ vmf->page = NULL;
+ return VM_FAULT_SIGBUS;
diff --git a/abs/core/nvidia-340xx/kernel-4.14.patch b/abs/core/nvidia-340xx/kernel-4.14.patch
new file mode 100644
index 0000000..a38adbd
--- /dev/null
+++ b/abs/core/nvidia-340xx/kernel-4.14.patch
@@ -0,0 +1,29 @@
+diff -u -r NVIDIA-Linux-x86_64-340.104-no-compat32/kernel/nv-drm.c NVIDIA-Linux-x86_64-340.104-no-compat32-kernel4.14/kernel/nv-drm.c
+--- NVIDIA-Linux-x86_64-340.104-no-compat32/kernel/nv-drm.c 2017-09-15 01:16:51.000000000 +0200
++++ NVIDIA-Linux-x86_64-340.104-no-compat32-kernel4.14/kernel/nv-drm.c 2017-11-19 00:51:45.006654148 +0100
+@@ -173,8 +173,12 @@
+ {
+ int ret = 0;
+ #if defined(NV_DRM_AVAILABLE)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 14, 0)
++ ret = drm_legacy_pci_init(&nv_drm_driver, pci_driver);
++#else
+ ret = drm_pci_init(&nv_drm_driver, pci_driver);
+ #endif
++#endif
+ return ret;
+ }
+
+@@ -183,8 +187,12 @@
+ )
+ {
+ #if defined(NV_DRM_AVAILABLE)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 14, 0)
++ drm_legacy_pci_exit(&nv_drm_driver, pci_driver);
++#else
+ drm_pci_exit(&nv_drm_driver, pci_driver);
+ #endif
++#endif
+ }
+
+ RM_STATUS NV_API_CALL nv_alloc_os_descriptor_handle(
diff --git a/abs/core/nvidia-340xx/nvidia-340xx.install b/abs/core/nvidia-340xx/nvidia-340xx.install
deleted file mode 100644
index 9858d46..0000000
--- a/abs/core/nvidia-340xx/nvidia-340xx.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- EXTRAMODULES='extramodules-4.9-ARCH'
- depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
- echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}