summaryrefslogtreecommitdiffstats
path: root/abs/core/nvidia-340xx
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-09-30 20:21:06 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-09-30 20:21:06 (GMT)
commitd685308565e7fe194211b8c917c341be29ee7bcf (patch)
tree3d6879a578283425d28db7fda4750a73d0f16750 /abs/core/nvidia-340xx
parent6c2b1fd27461934e9eaa8a715de2a2cee469ed06 (diff)
downloadlinhes_pkgbuild-d685308565e7fe194211b8c917c341be29ee7bcf.zip
linhes_pkgbuild-d685308565e7fe194211b8c917c341be29ee7bcf.tar.gz
linhes_pkgbuild-d685308565e7fe194211b8c917c341be29ee7bcf.tar.bz2
nvidia-340xx & nvidia-340xx-utils: update to 340.98
Diffstat (limited to 'abs/core/nvidia-340xx')
-rw-r--r--abs/core/nvidia-340xx/PKGBUILD18
-rw-r--r--abs/core/nvidia-340xx/nvidia-340xx-dkms.install30
2 files changed, 9 insertions, 39 deletions
diff --git a/abs/core/nvidia-340xx/PKGBUILD b/abs/core/nvidia-340xx/PKGBUILD
index 9f7dcad..03eb794 100644
--- a/abs/core/nvidia-340xx/PKGBUILD
+++ b/abs/core/nvidia-340xx/PKGBUILD
@@ -4,19 +4,19 @@
pkgbase=nvidia-340xx
pkgname=(nvidia-340xx nvidia-340xx-dkms)
-pkgver=340.96
+pkgver=340.98
_extramodules=extramodules-4.4-ARCH
-pkgrel=8
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
makedepends=("nvidia-340xx-libgl=${pkgver}" "nvidia-340xx-utils=${pkgver}" 'linux' 'linux-headers>=4.4' 'linux-headers<4.5')
conflicts=('nvidia')
license=('custom')
options=(!strip)
-source_i686+=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
-source_x86_64+=("ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-md5sums_i686=('cb64b165b638671bcdc75bcf297b8d90')
-md5sums_x86_64=('7bdbcee13bade63227933d9217571882')
+source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+md5sums_i686=('3ccb023eec137cbee0d2035c288b6bbe')
+md5sums_x86_64=('e8d1292d8d002a15e10ea349151fa8f2')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
@@ -25,6 +25,8 @@ prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
# patches here
+
+ cp -a kernel kernel-dkms
}
build() {
@@ -57,12 +59,10 @@ package_nvidia-340xx-dkms() {
optdepends=('linux-headers: Build the module for Arch kernel'
'linux-lts-headers: Build the module for LTS Arch kernel')
conflicts+=('nvidia-340xx')
- install=nvidia-340xx-dkms.install
cd ${_pkg}
- make -C kernel clean
install -dm 755 "${pkgdir}"/usr/{lib/modprobe.d,src}
- cp -dr --no-preserve='ownership' kernel "${pkgdir}"/usr/src/nvidia-${pkgver}
+ cp -dr --no-preserve='ownership' kernel-dkms "${pkgdir}"/usr/src/nvidia-${pkgver}
echo 'blacklist nouveau' > "${pkgdir}"/usr/lib/modprobe.d/nvidia.conf
cat "${pkgdir}"/usr/src/nvidia-${pkgver}/uvm/dkms.conf.fragment >> "${pkgdir}"/usr/src/nvidia-${pkgver}/dkms.conf
}
diff --git a/abs/core/nvidia-340xx/nvidia-340xx-dkms.install b/abs/core/nvidia-340xx/nvidia-340xx-dkms.install
deleted file mode 100644
index 3d9b74d..0000000
--- a/abs/core/nvidia-340xx/nvidia-340xx-dkms.install
+++ /dev/null
@@ -1,30 +0,0 @@
-#/bin/sh
-
-# arg 1: the new package version
-post_install() {
- dkms add nvidia/${1%-*}
- cat << EOF
-==> To build and install your modules run: dkms install nvidia/${1%-*}
-==> To do this automatically at startup run: systemctl enable dkms.service
-EOF
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-pre_upgrade() {
- pre_remove "$2"
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install "$1"
-}
-
-# arg 1: the old package version
-pre_remove() {
- # Remove modules using dkms
- [ -n "${1%-*}" ] && dkms remove nvidia/${1%-*} --all &>/dev/null || true
-}
-
-# vim:set ts=2 sw=2 ft=sh et: