summaryrefslogtreecommitdiffstats
path: root/abs/core/openssl
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-03-14 19:21:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-03-14 19:21:23 (GMT)
commit47f205ef492e07410c2e410fe42abb2e62a7f682 (patch)
tree5d85566c2e57e82bed5c3c61ec9a7806fa0312b0 /abs/core/openssl
parentf2191d604ffdd618cb2b74428f26cb817e0153ab (diff)
downloadlinhes_pkgbuild-47f205ef492e07410c2e410fe42abb2e62a7f682.zip
linhes_pkgbuild-47f205ef492e07410c2e410fe42abb2e62a7f682.tar.gz
linhes_pkgbuild-47f205ef492e07410c2e410fe42abb2e62a7f682.tar.bz2
openssl: update to 1.0.2.g
Diffstat (limited to 'abs/core/openssl')
-rw-r--r--abs/core/openssl/PKGBUILD16
-rw-r--r--abs/core/openssl/ssl3-test-failure.patch26
2 files changed, 37 insertions, 5 deletions
diff --git a/abs/core/openssl/PKGBUILD b/abs/core/openssl/PKGBUILD
index a1627f3..8752c9d 100644
--- a/abs/core/openssl/PKGBUILD
+++ b/abs/core/openssl/PKGBUILD
@@ -2,26 +2,28 @@
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=openssl
-_ver=1.0.2f
+_ver=1.0.2g
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
#pkgver=$_ver
-pkgrel=1
+pkgrel=3
pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security'
arch=('i686' 'x86_64')
url='https://www.openssl.org'
license=('custom:BSD')
-depends=('zlib' 'perl')
+depends=('perl')
optdepends=('ca-certificates')
options=('!makeflags')
backup=('etc/ssl/openssl.cnf')
source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"
"https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz.asc"
'no-rpath.patch'
+ 'ssl3-test-failure.patch'
'ca-dir.patch')
-md5sums=('b3bf73f507172be9292ea2a8c28b659d'
+md5sums=('f3c710c045cdee5fd114feb69feba7aa'
'SKIP'
'dc78d3d06baffc16217519242ce92478'
+ '62fc492252edd3283871632bb77fadbe'
'3bf51be3a1bbd262be46dc619f92aa90')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491')
@@ -30,6 +32,10 @@ prepare() {
# remove rpath: http://bugs.archlinux.org/task/14367
patch -p0 -i $srcdir/no-rpath.patch
+
+ # disable a test that fails when ssl3 is disabled
+ patch -p1 -i $srcdir/ssl3-test-failure.patch
+
# set ca dir to /etc/ssl by default
patch -p0 -i $srcdir/ca-dir.patch
}
@@ -47,7 +53,7 @@ build() {
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
- shared zlib ${optflags} \
+ shared no-ssl3-method ${optflags} \
"${openssltarget}" \
"-Wa,--noexecstack ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
diff --git a/abs/core/openssl/ssl3-test-failure.patch b/abs/core/openssl/ssl3-test-failure.patch
new file mode 100644
index 0000000..d161c3d
--- /dev/null
+++ b/abs/core/openssl/ssl3-test-failure.patch
@@ -0,0 +1,26 @@
+From: Kurt Roeckx <kurt@roeckx.be>
+Date: Sun, 6 Sep 2015 16:04:11 +0200
+Subject: Disable SSLv3 test in test suite
+
+When testing SSLv3 the test program returns 0 for skip. The test for weak DH
+expects a failure, but gets success.
+
+It should probably be changed to return something other than 0 for a skipped
+test.
+---
+ test/testssl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/testssl b/test/testssl
+index 747e4ba..1e4370b 100644
+--- a/test/testssl
++++ b/test/testssl
+@@ -160,7 +160,7 @@ test_cipher() {
+ }
+
+ echo "Testing ciphersuites"
+-for protocol in TLSv1.2 SSLv3; do
++for protocol in TLSv1.2; do
+ echo "Testing ciphersuites for $protocol"
+ for cipher in `../util/shlib_wrap.sh ../apps/openssl ciphers "RSA+$protocol" | tr ':' ' '`; do
+ test_cipher $cipher $protocol