summaryrefslogtreecommitdiffstats
path: root/abs/core/p11-kit
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 17:49:07 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 17:49:07 (GMT)
commitc22764f957f0d2dd94b4f8e4ccac0ffe71f65e71 (patch)
treedef9a6aa2eb23719e97da83916158802f676f23f /abs/core/p11-kit
parent91e7acec7805190f4080d6cab79ac824375755ce (diff)
downloadlinhes_pkgbuild-c22764f957f0d2dd94b4f8e4ccac0ffe71f65e71.zip
linhes_pkgbuild-c22764f957f0d2dd94b4f8e4ccac0ffe71f65e71.tar.gz
linhes_pkgbuild-c22764f957f0d2dd94b4f8e4ccac0ffe71f65e71.tar.bz2
p11-kit 0.12
-new
Diffstat (limited to 'abs/core/p11-kit')
-rw-r--r--abs/core/p11-kit/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/core/p11-kit/PKGBUILD b/abs/core/p11-kit/PKGBUILD
new file mode 100644
index 0000000..639a279
--- /dev/null
+++ b/abs/core/p11-kit/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 154982 2012-04-01 07:46:19Z ibiru $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=p11-kit
+pkgver=0.12
+pkgrel=1
+pkgdesc="Library to work with PKCS#11 modules"
+arch=(i686 x86_64)
+url="http://p11-glue.freedesktop.org"
+license=('BSD')
+depends=(glibc)
+options=(!libtool)
+source=($url/releases/$pkgname-$pkgver.tar.gz)
+md5sums=('66baf7ddde982d1b7294d3bd63be7446')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --with-module-path=/usr/lib/pkcs11
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
+
+# vim:set ts=2 sw=2 et: