summaryrefslogtreecommitdiffstats
path: root/abs/core/pacman
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-07-12 05:09:57 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-07-12 05:09:57 (GMT)
commit88275f98d5fac50c978e4fbdc9f7d418aee638ce (patch)
treed04f17a227bf8f536fb79cd6d1d9692a348ffa89 /abs/core/pacman
parenta70ac378c70ce2ad383c07eb41615df9536ff32d (diff)
downloadlinhes_pkgbuild-88275f98d5fac50c978e4fbdc9f7d418aee638ce.zip
linhes_pkgbuild-88275f98d5fac50c978e4fbdc9f7d418aee638ce.tar.gz
linhes_pkgbuild-88275f98d5fac50c978e4fbdc9f7d418aee638ce.tar.bz2
pacman: Bumped to latest
Diffstat (limited to 'abs/core/pacman')
-rw-r--r--abs/core/pacman/PKGBUILD39
-rw-r--r--abs/core/pacman/makepkg.conf9
-rw-r--r--abs/core/pacman/pacman.conf4
-rw-r--r--abs/core/pacman/pacman.conf.x86_649
-rw-r--r--abs/core/pacman/pacman.install29
5 files changed, 51 insertions, 39 deletions
diff --git a/abs/core/pacman/PKGBUILD b/abs/core/pacman/PKGBUILD
index 2d4f776..59ff582 100644
--- a/abs/core/pacman/PKGBUILD
+++ b/abs/core/pacman/PKGBUILD
@@ -1,15 +1,15 @@
-# $Id: PKGBUILD 89780 2010-09-04 01:05:26Z dan $
+# $Id$
# Maintainer: Dan McGee <dan@archlinux.org>
pkgname=pacman
-pkgver=3.4.1
-pkgrel=3
+pkgver=3.5.3
+pkgrel=1
pkgdesc="A library-based package manager with dependency support"
arch=('i686' 'x86_64')
url="http://www.archlinux.org/pacman/"
license=('GPL')
groups=('base')
-depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25' 'pacman-mirrorlist')
+depends=('bash' 'libarchive>=2.8.4' 'libfetch>=2.28' 'pacman-mirrorlist')
optdepends=('fakeroot: for makepkg usage as normal user'
'curl: for rankmirrors usage')
backup=(etc/pacman.conf etc/makepkg.conf)
@@ -19,44 +19,43 @@ source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
pacman.conf
pacman.conf.x86_64
makepkg.conf)
+md5sums=('b4f1fdbc17100923071ebe8fe9377be5'
+ 'e99eb721b6b704f68c5f47468507c102'
+ 'f8b939d9b2beb79a0436961a2d707d7c'
+ 'a8684989d3dfad5a6e1bcf95af3e571b')
# keep an upgrade path for older installations
PKGEXT='.pkg.tar.gz'
build() {
cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc
- make || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --enable-doc
+ make
}
package() {
cd $srcdir/$pkgname-$pkgver
- make DESTDIR=$pkgdir install || return 1
+ make DESTDIR=$pkgdir install
# install Arch specific stuff
mkdir -p $pkgdir/etc
case "$CARCH" in
i686)
install -m644 $srcdir/pacman.conf $pkgdir/etc/pacman.conf
- ;;
- x86_64)
- install -m644 $srcdir/pacman.conf.x86_64 $pkgdir/etc/pacman.conf
- ;;
- esac
- install -m644 $srcdir/makepkg.conf $pkgdir/etc/
- # set things correctly in the default conf file
- case "$CARCH" in
- i686)
mycarch="i686"
mychost="i686-pc-linux-gnu"
myflags="-march=i686 "
;;
x86_64)
+ install -m644 $srcdir/pacman.conf.x86_64 $pkgdir/etc/pacman.conf
mycarch="x86_64"
mychost="x86_64-unknown-linux-gnu"
myflags="-march=x86-64 "
;;
esac
+ install -m644 $srcdir/makepkg.conf $pkgdir/etc/
+ # set things correctly in the default conf file
sed -i $pkgdir/etc/makepkg.conf \
-e "s|@CARCH[@]|$mycarch|g" \
-e "s|@CHOST[@]|$mychost|g" \
@@ -70,7 +69,7 @@ package() {
}
# vim: set ts=2 sw=2 et:
-md5sums=('4e4e8e4f636d9878fbed9cf840f162cf'
- '4792e61cd1b902d20046e19f97ae758d'
- '9ba146b4fa7bcb3cc18204b06d1f6157'
- 'aef317285c7d16ac495b0e53deeb948d')
+md5sums=('c36c18ed4d8ec69c0ecb4f9684266901'
+ '8f7e5462469cfc7520b3aade58ff28de'
+ 'f8b939d9b2beb79a0436961a2d707d7c'
+ 'a8684989d3dfad5a6e1bcf95af3e571b')
diff --git a/abs/core/pacman/makepkg.conf b/abs/core/pacman/makepkg.conf
index ff08a0f..a655e93 100644
--- a/abs/core/pacman/makepkg.conf
+++ b/abs/core/pacman/makepkg.conf
@@ -39,15 +39,16 @@ LDFLAGS="-Wl,--hash-style=gnu -Wl,--as-needed"
# BUILD ENVIRONMENT
#########################################################################
#
-# Defaults: BUILDENV=(fakeroot !distcc color !ccache)
+# Defaults: BUILDENV=(fakeroot !distcc color !ccache check)
# A negated environment option will do the opposite of the comments below.
#
#-- fakeroot: Allow building packages as a non-root user
#-- distcc: Use the Distributed C/C++/ObjC compiler
#-- color: Colorize output messages
#-- ccache: Use ccache to cache compilation
+#-- check: Run the check() function if present in the PKGBUILD
#
-BUILDENV=(fakeroot !distcc color !ccache)
+BUILDENV=(fakeroot !distcc color !ccache check)
#
#-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
#-- specify a space-delimited list of hosts running in the DistCC cluster.
@@ -61,7 +62,7 @@ BUILDENV=(fakeroot !distcc color !ccache)
# Default: OPTIONS=(strip docs libtool emptydirs zipman purge)
# A negated option will do the opposite of the comments below.
#
-#-- strip: Strip symbols from binaries/libraries in STRIP_DIRS
+#-- strip: Strip symbols from binaries/libraries
#-- docs: Save doc directories specified by DOC_DIRS
#-- libtool: Leave libtool (.la) files in packages
#-- emptydirs: Leave empty directories in packages
@@ -82,8 +83,6 @@ STRIP_STATIC="--strip-debug"
MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
#-- Doc directories to remove (if !docs is specified)
DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
-#-- Directories to be searched for the strip option (if strip is specified)
-STRIP_DIRS=(bin lib sbin usr/{bin,lib,sbin,local/{bin,lib,sbin}} opt/*/{bin,lib,sbin})
#-- Files to be removed from all packages (if purge is specified)
PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
diff --git a/abs/core/pacman/pacman.conf b/abs/core/pacman/pacman.conf
index c44d2e6..ae584e2 100644
--- a/abs/core/pacman/pacman.conf
+++ b/abs/core/pacman/pacman.conf
@@ -17,7 +17,7 @@ HoldPkg = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst = pacman
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
-#XferCommand = /usr/bin/curl -C - %u > %o
+#XferCommand = /usr/bin/curl -C - -f %u > %o
#CleanMethod = KeepInstalled
Architecture = auto
@@ -33,6 +33,7 @@ Architecture = auto
#ShowSize
#UseDelta
#TotalDownload
+#CheckSpace
#
# REPOSITORIES
@@ -76,4 +77,3 @@ Include = /etc/pacman.d/mirrorlist
# tips on creating your own repositories.
#[custom]
#Server = file:///home/custompkgs
-
diff --git a/abs/core/pacman/pacman.conf.x86_64 b/abs/core/pacman/pacman.conf.x86_64
index e825b4b..6f04236 100644
--- a/abs/core/pacman/pacman.conf.x86_64
+++ b/abs/core/pacman/pacman.conf.x86_64
@@ -17,7 +17,7 @@ HoldPkg = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst = pacman
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
-#XferCommand = /usr/bin/curl -C - %u > %o
+#XferCommand = /usr/bin/curl -C - -f %u > %o
#CleanMethod = KeepInstalled
Architecture = auto
@@ -33,6 +33,7 @@ Architecture = auto
#ShowSize
#UseDelta
#TotalDownload
+#CheckSpace
#
# REPOSITORIES
@@ -73,7 +74,11 @@ Include = /etc/pacman.d/mirrorlist
Include = /etc/pacman.d/mirrorlist
# If you want to run 32 bit applications on your x86_64 system,
-# enable the multilib repository here.
+# enable the multilib repositories as required here.
+
+#[multilib-testing]
+#Include = /etc/pacman.d/mirrorlist
+
#[multilib]
#Include = /etc/pacman.d/mirrorlist
diff --git a/abs/core/pacman/pacman.install b/abs/core/pacman/pacman.install
index 294222e..b735399 100644
--- a/abs/core/pacman/pacman.install
+++ b/abs/core/pacman/pacman.install
@@ -2,19 +2,28 @@
# arg 1: the new package version
# arg 2: the old package version
post_upgrade() {
- # one time stuff for md5sum issue with older pacman versions
- if [ "$(vercmp $2 3.0.2)" -lt 0 ]; then
- _resetbackups
- fi
+ # one time stuff for md5sum issue with older pacman versions
+ if [ "$(vercmp $2 3.0.2)" -lt 0 ]; then
+ _resetbackups
+ fi
+ if [ "$(vercmp $2 3.5.0)" -lt 0 ]; then
+ _warnupgrade
+ fi
+}
+
+_warnupgrade() {
+ echo ">>> The pacman database format has changed as of pacman 3.5.0."
+ echo ">>> You will need to run \`pacman-db-upgrade\` as root."
+ echo ">>>"
}
_resetbackups() {
- echo ">>> Performing one-time reset of NoUpgrade md5sums. After this reset"
- echo ">>> you are able to remove all NoUpgrade lines of already protected"
- echo ">>> files from pacman.conf."
- echo ">>>"
+ echo ">>> Performing one-time reset of NoUpgrade md5sums. After this reset"
+ echo ">>> you are able to remove all NoUpgrade lines of already protected"
+ echo ">>> files from pacman.conf."
+ echo ">>>"
- # path variables
+ # path variables
pacconf="/etc/pacman.conf"
dbpath="/var/lib/pacman/local"
@@ -50,4 +59,4 @@ _resetbackups() {
echo ">>> -> $file is unowned."
fi
done
-}
+}