summaryrefslogtreecommitdiffstats
path: root/abs/core/pam
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/pam
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/pam')
-rw-r--r--abs/core/pam/PKGBUILD50
-rw-r--r--abs/core/pam/other5
-rw-r--r--abs/core/pam/pam.install22
3 files changed, 77 insertions, 0 deletions
diff --git a/abs/core/pam/PKGBUILD b/abs/core/pam/PKGBUILD
new file mode 100644
index 0000000..4bdca6a
--- /dev/null
+++ b/abs/core/pam/PKGBUILD
@@ -0,0 +1,50 @@
+# $Id: PKGBUILD 3761 2008-06-30 20:27:30Z andyrtr $
+# Maintainer: judd <jvinet@zeroflux.org>
+pkgname=pam
+pkgver=1.0.1
+pkgrel=11
+pkgdesc="PAM (Pluggable Authentication Modules) library"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://www.kernel.org/pub/linux/libs/pam/"
+groups=('base')
+depends=('glibc' 'db>=4.7' 'cracklib')
+backup=(etc/security/{access.conf,group.conf,limits.conf,namespace.conf,namespace.init,pam_env.conf,time.conf} etc/pam.d/other etc/default/passwd etc/environment)
+source=(http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2 \
+ ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2/pam_unix2-2.1.tar.bz2 \
+ other)
+options=('!libtool' '!emptydirs')
+md5sums=('1c75f81bd44c5da93014992820917847'
+ '08d3bc1940897b5dfcbe2f51dd979ad0'
+ '6e6c8719e5989d976a14610f340bd33a')
+
+build() {
+ cd $startdir/src/Linux-PAM-$pkgver
+ ./configure --sysconfdir=/etc DESTDIR=$startdir/pkg --libdir=/lib
+ make || return 1
+ make INSTALL=/bin/install DESTDIR=$startdir/pkg install
+ install -D -m644 ../other $startdir/pkg/etc/pam.d/other
+ # build pam_unix2 module
+ # source ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2
+ cd $startdir/src/pam_unix2-2.1
+ ./configure
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ # add the realtime permissions for audio users
+ sed -i 's|# End of file||' $startdir/pkg/etc/security/limits.conf
+ cat >>$startdir/pkg/etc/security/limits.conf <<_EOT
+* - rtprio 0
+* - nice 0
+@audio - rtprio 65
+@audio - nice -10
+@audio - memlock 40000
+_EOT
+ # fix some missing symlinks from old pam for compatibility
+ cd $startdir/pkg/lib/security
+ ln -s pam_unix.so pam_unix_acct.so
+ ln -s pam_unix.so pam_unix_auth.so
+ ln -s pam_unix.so pam_unix_passwd.so
+ ln -s pam_unix.so pam_unix_session.so
+ # set unix_chkpwd uid
+ chmod +s $startdir/pkg/sbin/unix_chkpwd
+}
diff --git a/abs/core/pam/other b/abs/core/pam/other
new file mode 100644
index 0000000..08498b4
--- /dev/null
+++ b/abs/core/pam/other
@@ -0,0 +1,5 @@
+#%PAM-1.0
+auth required pam_unix.so
+account required pam_unix.so
+password required pam_unix.so
+session required pam_unix.so
diff --git a/abs/core/pam/pam.install b/abs/core/pam/pam.install
new file mode 100644
index 0000000..eb0899c
--- /dev/null
+++ b/abs/core/pam/pam.install
@@ -0,0 +1,22 @@
+# arg 1: the new package version
+post_install() {
+ # need to run this immediately -- pacman only runs it at the end of
+ # all package installs
+ /sbin/ldconfig -r .
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*