summaryrefslogtreecommitdiffstats
path: root/abs/core/pam
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-07 15:04:43 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-07 15:04:43 (GMT)
commit4203446deb4124c2a774cf485fcb79cc757cc8d4 (patch)
treee30d767fe1b9f346b438333c877f0d38c4df86a5 /abs/core/pam
parent37ac848c79d400adba788a443e2a8650079dfe90 (diff)
downloadlinhes_pkgbuild-4203446deb4124c2a774cf485fcb79cc757cc8d4.zip
linhes_pkgbuild-4203446deb4124c2a774cf485fcb79cc757cc8d4.tar.gz
linhes_pkgbuild-4203446deb4124c2a774cf485fcb79cc757cc8d4.tar.bz2
pam: 1.1.6
Diffstat (limited to 'abs/core/pam')
-rw-r--r--abs/core/pam/PKGBUILD32
-rw-r--r--abs/core/pam/__changelog1
-rw-r--r--abs/core/pam/pam_namespace-build-1.1.6.patch11
-rw-r--r--abs/core/pam/pam_unix2-glibc216.patch20
4 files changed, 49 insertions, 15 deletions
diff --git a/abs/core/pam/PKGBUILD b/abs/core/pam/PKGBUILD
index a778adc..1e7c611 100644
--- a/abs/core/pam/PKGBUILD
+++ b/abs/core/pam/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 161792 2012-06-14 10:14:53Z tpowa $
+# $Id: PKGBUILD 168736 2012-10-15 05:13:56Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=pam
-pkgver=1.1.5
-pkgrel=4
+pkgver=1.1.6
+pkgrel=1
pkgdesc="PAM (Pluggable Authentication Modules) library"
arch=('i686' 'x86_64')
license=('GPL2')
@@ -14,31 +14,35 @@ makedepends=('flex' 'w3m' 'docbook-xml>=4.4' 'docbook-xsl')
backup=(etc/security/{access.conf,group.conf,limits.conf,namespace.conf,namespace.init,pam_env.conf,time.conf} etc/default/passwd etc/environment)
source=(https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-$pkgver.tar.bz2
#http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2
- ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2/pam_unix2-2.6.tar.bz2)
+ ftp://ftp.archlinux.org/other/pam_unix2/pam_unix2-2.9.1.tar.bz2
+ pam_unix2-glibc216.patch
+ pam_namespace-build-1.1.6.patch)
options=('!libtool' '!emptydirs')
-md5sums=('927ee5585bdec5256c75117e9348aa47'
- 'e2788389a6c59224110a45fcff30e02b')
+md5sums=('7b73e58b7ce79ffa321d408de06db2c4'
+ 'da6a46e5f8cd3eaa7cbc4fc3a7e2b555'
+ 'dac109f68e04a4df37575fda6001ea17'
+ '440a510164ba5eb69bf41e129746ff44')
build() {
cd $srcdir/Linux-PAM-$pkgver
- sed -i '1 i#include <sys/resource.h>' modules/pam_unix/pam_unix_auth.c
- sed -i '1 i#include <sys/resource.h>' modules/pam_unix/pam_unix_acct.c
./configure --libdir=/usr/lib
+ patch -Np0 -i ../pam_namespace-build-1.1.6.patch
make
- # cd $srcdir/pam_unix2-2.6
- # ./configure --libdir=/usr/lib
-# make
+ cd $srcdir/pam_unix2-2.9.1
+ patch -Np1 -i ../pam_unix2-glibc216.patch
+ ./configure --libdir=/usr/lib
+ make
}
package() {
cd $srcdir/Linux-PAM-$pkgver
- make DESTDIR=$pkgdir install
+ make DESTDIR=$pkgdir SCONFIGDIR=/etc/security install
# build pam_unix2 module
# source ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2
-# cd $srcdir/pam_unix2-2.6
-# make DESTDIR=$pkgdir install
+ cd $srcdir/pam_unix2-2.9.1
+ make DESTDIR=$pkgdir install
# add the realtime permissions for audio users
sed -i 's|# End of file||' $pkgdir/etc/security/limits.conf
diff --git a/abs/core/pam/__changelog b/abs/core/pam/__changelog
deleted file mode 100644
index 4e18340..0000000
--- a/abs/core/pam/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-https://bugs.archlinux.org/task/30645
diff --git a/abs/core/pam/pam_namespace-build-1.1.6.patch b/abs/core/pam/pam_namespace-build-1.1.6.patch
new file mode 100644
index 0000000..aeabc23
--- /dev/null
+++ b/abs/core/pam/pam_namespace-build-1.1.6.patch
@@ -0,0 +1,11 @@
+--- modules/pam_namespace/Makefile~ 2012-10-12 10:59:13.557550706 +0200
++++ modules/pam_namespace/Makefile 2012-10-12 10:59:13.564217270 +0200
+@@ -869,7 +869,7 @@
+
+
+ install-data-local:
+- mkdir -p $(namespaceddir)
++ mkdir -p $(DESTDIR)$(namespaceddir)
+ README: pam_namespace.8.xml namespace.conf.5.xml
+ -include $(top_srcdir)/Make.xml.rules
+
diff --git a/abs/core/pam/pam_unix2-glibc216.patch b/abs/core/pam/pam_unix2-glibc216.patch
new file mode 100644
index 0000000..faa6a23
--- /dev/null
+++ b/abs/core/pam/pam_unix2-glibc216.patch
@@ -0,0 +1,20 @@
+Index: pam_unix2-2.9.1/src/read-files.c
+===================================================================
+--- pam_unix2-2.9.1.orig/src/read-files.c
++++ pam_unix2-2.9.1/src/read-files.c
+@@ -30,8 +30,14 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <nss.h>
+-#include <bits/libc-lock.h>
++#include <pthread.h>
+ #define __libc_lock_t pthread_mutex_t
++#define __libc_lock_define_initialized(CLASS,NAME) \
++ CLASS __libc_lock_t NAME = PTHREAD_MUTEX_INITIALIZER;
++#define __libc_lock_lock(NAME) \
++ pthread_mutex_lock, (&(NAME))
++#define __libc_lock_unlock(NAME) \
++ pthread_mutex_unlock, (&(NAME))
+
+ #include "read-files.h"
+