summaryrefslogtreecommitdiffstats
path: root/abs/core/pam
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-23 02:35:39 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-23 02:35:39 (GMT)
commit9cc958d6f37c0e45f67b4917c73dbbf4824c8e69 (patch)
treeae1ae451e72a42df2558505de1048fc5db48f5b3 /abs/core/pam
parent2fb5be316775deb74054f7854c26aa6cda80c57e (diff)
downloadlinhes_pkgbuild-9cc958d6f37c0e45f67b4917c73dbbf4824c8e69.zip
linhes_pkgbuild-9cc958d6f37c0e45f67b4917c73dbbf4824c8e69.tar.gz
linhes_pkgbuild-9cc958d6f37c0e45f67b4917c73dbbf4824c8e69.tar.bz2
pam: upgrade to 1.1.3 NOTE: ABS only has up to 1.1.2 -- went beyond that
Diffstat (limited to 'abs/core/pam')
-rw-r--r--abs/core/pam/PKGBUILD27
-rw-r--r--abs/core/pam/pam.install10
2 files changed, 14 insertions, 23 deletions
diff --git a/abs/core/pam/PKGBUILD b/abs/core/pam/PKGBUILD
index 63108ea..05f8837 100644
--- a/abs/core/pam/PKGBUILD
+++ b/abs/core/pam/PKGBUILD
@@ -1,35 +1,33 @@
-# $Id: PKGBUILD 29514 2009-03-09 17:33:55Z tpowa $
-# Maintainer: judd <jvinet@zeroflux.org>
+# $Id: PKGBUILD 96216 2010-10-19 11:54:04Z allan $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
pkgname=pam
-pkgver=1.0.4
+pkgver=1.1.3
pkgrel=1
pkgdesc="PAM (Pluggable Authentication Modules) library"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.kernel.org/pub/linux/libs/pam/"
-groups=('base')
-depends=('glibc' 'db>=4.7' 'cracklib')
+depends=('glibc' 'db' 'cracklib')
makedepends=('flex')
backup=(etc/security/{access.conf,group.conf,limits.conf,namespace.conf,namespace.init,pam_env.conf,time.conf} etc/pam.d/other etc/default/passwd etc/environment)
-source=(http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2 \
- ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2/pam_unix2-2.6.tar.bz2 \
+source=(http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2
+ ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2/pam_unix2-2.6.tar.bz2
other)
options=('!libtool' '!emptydirs')
-md5sums=('189171821b56aaf791cc890d0707ea82'
- 'e2788389a6c59224110a45fcff30e02b'
- '6e6c8719e5989d976a14610f340bd33a')
build() {
cd $srcdir/Linux-PAM-$pkgver
./configure --sysconfdir=/etc DESTDIR=$pkgdir --libdir=/lib
- make || return 1
+ make
make INSTALL=/bin/install DESTDIR=$pkgdir install
install -D -m644 ../other $pkgdir/etc/pam.d/other
# build pam_unix2 module
# source ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2
cd $srcdir/pam_unix2-2.6
./configure
- make || return 1
+ make
make DESTDIR=$pkgdir install
# add the realtime permissions for audio users
sed -i 's|# End of file||' $pkgdir/etc/security/limits.conf
@@ -49,3 +47,6 @@ _EOT
# set unix_chkpwd uid
chmod +s $pkgdir/sbin/unix_chkpwd
}
+md5sums=('6db7fcb5db6253350e3a4648ceac40e7'
+ 'e2788389a6c59224110a45fcff30e02b'
+ '6e6c8719e5989d976a14610f340bd33a')
diff --git a/abs/core/pam/pam.install b/abs/core/pam/pam.install
index eb0899c..9d45880 100644
--- a/abs/core/pam/pam.install
+++ b/abs/core/pam/pam.install
@@ -10,13 +10,3 @@ post_install() {
post_upgrade() {
post_install $1
}
-
-# arg 1: the old package version
-pre_remove() {
- /bin/true
-}
-
-op=$1
-shift
-
-$op $*