summaryrefslogtreecommitdiffstats
path: root/abs/core/parted/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/parted/PKGBUILD
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/parted/PKGBUILD')
-rw-r--r--abs/core/parted/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/core/parted/PKGBUILD b/abs/core/parted/PKGBUILD
new file mode 100644
index 0000000..b65a9ca
--- /dev/null
+++ b/abs/core/parted/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+
+pkgname=parted
+pkgver=1.8.8
+pkgrel=1
+pkgdesc="A program for creating, destroying, resizing, checking and copying partitions"
+arch=(i686 x86_64)
+license=('GPL3')
+url="http://www.gnu.org/software/parted/parted.html"
+depends=('e2fsprogs')
+source=(ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz parted-1.7.1-fix-seg.patch)
+md5sums=('0d494591731082ec57cc18627728124a' '88f3c5b45fdd1d3dce70a1a19bf48481')
+options=(!libtool)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ #Arch64 fix - still needed?
+ [ "$CARCH" = "x86_64" ] && patch -Np1 -i ../parted-1.7.1-fix-seg.patch
+ ./configure --prefix=/usr --disable-debug --disable-Werror
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}