summaryrefslogtreecommitdiffstats
path: root/abs/core/patch
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-08-24 21:08:00 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-08-24 21:08:00 (GMT)
commitc3d4612dd35fb69a7ba4273fea17d23e53032f2b (patch)
tree7139fc9a25763b72a1c0000dbc74e3743f4facc7 /abs/core/patch
parent9dfd6694e4f8f7bc4c8e969f3419c8bbd0e7fd33 (diff)
downloadlinhes_pkgbuild-c3d4612dd35fb69a7ba4273fea17d23e53032f2b.zip
linhes_pkgbuild-c3d4612dd35fb69a7ba4273fea17d23e53032f2b.tar.gz
linhes_pkgbuild-c3d4612dd35fb69a7ba4273fea17d23e53032f2b.tar.bz2
patch: update to 2.7.5
Diffstat (limited to 'abs/core/patch')
-rw-r--r--abs/core/patch/PKGBUILD25
-rw-r--r--abs/core/patch/patch-2.7.1-initialize-data-structures-early-enough.patch81
2 files changed, 12 insertions, 94 deletions
diff --git a/abs/core/patch/PKGBUILD b/abs/core/patch/PKGBUILD
index 8171a3a..90c3b1e 100644
--- a/abs/core/patch/PKGBUILD
+++ b/abs/core/patch/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: judd <jvinet@zeroflux.org>
pkgname=patch
-pkgver=2.7.1
-pkgrel=3
+pkgver=2.7.5
+pkgrel=1
pkgdesc='A utility to apply patch files to original sources'
arch=('i686' 'x86_64')
url='http://www.gnu.org/software/patch/patch.html'
@@ -14,18 +14,17 @@ groups=('base-devel')
depends=('glibc' 'attr')
makedepends=('ed')
optdepends=('ed: for patch -e functionality')
-source=("ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig}
- 'patch-2.7.1-initialize-data-structures-early-enough.patch')
-md5sums=('e9ae5393426d3ad783a300a338c09b72'
- 'SKIP'
- 'dc6367a7cd49933d4006c246789e98da')
+validpgpkeys=('7768CE4B75E5236F1A374CEEC4C927CD5D1B36D7') # Andreas Gruenbacher
+source=("ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
+md5sums=('e3da7940431633fb65a01b91d3b7a27a'
+ 'SKIP')
-prepare() {
- # Fix segfault on non-numeric strip-count
- # (also segfaults on nonexistent directory passed to -d)
- # http://savannah.gnu.org/bugs/?37500
- patch -Np1 -d $pkgname-$pkgver < patch-2.7.1-initialize-data-structures-early-enough.patch
-}
+#prepare() {
+# # Fix segfault on non-numeric strip-count
+# # (also segfaults on nonexistent directory passed to -d)
+# # http://savannah.gnu.org/bugs/?37500
+# patch -Np1 -d $pkgname-$pkgver < patch-2.7.1-initialize-data-structures-early-enough.patch
+#}
build() {
cd $pkgname-$pkgver
diff --git a/abs/core/patch/patch-2.7.1-initialize-data-structures-early-enough.patch b/abs/core/patch/patch-2.7.1-initialize-data-structures-early-enough.patch
deleted file mode 100644
index 046edc3..0000000
--- a/abs/core/patch/patch-2.7.1-initialize-data-structures-early-enough.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 291ec175812b7ba291d124e4cf2fbf9efec590c8 Mon Sep 17 00:00:00 2001
-From: Andreas Gruenbacher <agruen@linbit.com>
-Date: Thu, 4 Oct 2012 12:33:09 +0200
-Subject: [PATCH] Initialize data structures early enough
-
-* src/patch.c (main): Initialize data structures early enough, before error
-paths can access them.
-* tests/bad-usage: Test bad command line usage.
-* tests/Makefile.am (TESTS): Add bad-usage here.
----
- src/patch.c | 8 ++++----
- tests/Makefile.am | 1 +
- tests/bad-usage | 18 ++++++++++++++++++
- 3 files changed, 23 insertions(+), 4 deletions(-)
- create mode 100644 tests/bad-usage
-
-diff --git a/src/patch.c b/src/patch.c
-index 828943b..0255fbb 100644
---- a/src/patch.c
-+++ b/src/patch.c
-@@ -150,6 +150,10 @@ main (int argc, char **argv)
- else if ((version_control = getenv ("VERSION_CONTROL")))
- version_control_context = "$VERSION_CONTROL";
-
-+ init_backup_hash_table ();
-+ init_files_to_delete ();
-+ init_files_to_output ();
-+
- /* parse switches */
- Argc = argc;
- Argv = argv;
-@@ -162,10 +166,6 @@ main (int argc, char **argv)
- if (make_backups | backup_if_mismatch)
- backup_type = get_version (version_control_context, version_control);
-
-- init_backup_hash_table ();
-- init_files_to_delete ();
-- init_files_to_output ();
--
- init_output (&outstate);
- if (outfile)
- outstate.ofp = open_outfile (outfile);
-diff --git a/tests/Makefile.am b/tests/Makefile.am
-index 02fc6de..5cea52d 100644
---- a/tests/Makefile.am
-+++ b/tests/Makefile.am
-@@ -20,6 +20,7 @@ TESTS = \
- asymmetric-hunks \
- backup-prefix-suffix \
- bad-filenames \
-+ bad-usage \
- concat-git-diff \
- copy-rename \
- corrupt-reject-files \
-diff --git a/tests/bad-usage b/tests/bad-usage
-new file mode 100644
-index 0000000..022eeda
---- /dev/null
-+++ b/tests/bad-usage
-@@ -0,0 +1,18 @@
-+# Copyright (C) 2009, 2011-2012 Free Software Foundation, Inc.
-+#
-+# Copying and distribution of this file, with or without modification,
-+# in any medium, are permitted without royalty provided the copyright
-+# notice and this notice are preserved.
-+
-+. $srcdir/test-lib.sh
-+
-+require_cat
-+use_local_patch
-+use_tmpdir
-+
-+# ==============================================================
-+
-+check 'patch -px || echo "status: $?"' <<EOF
-+$PATCH: **** strip count x is not a number
-+status: 2
-+EOF
---
-1.8.0.3
-