summaryrefslogtreecommitdiffstats
path: root/abs/core/pcre
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-02 21:28:55 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-02 21:28:55 (GMT)
commit0d150db0f984b34cd2016171d21c98bf29e1a9e1 (patch)
treec92a711ab9c09199cf6beeed56c675369644a3eb /abs/core/pcre
parent84756879f17a8dd9acaca32e7edfee5cdeb2dbb8 (diff)
downloadlinhes_pkgbuild-0d150db0f984b34cd2016171d21c98bf29e1a9e1.zip
linhes_pkgbuild-0d150db0f984b34cd2016171d21c98bf29e1a9e1.tar.gz
linhes_pkgbuild-0d150db0f984b34cd2016171d21c98bf29e1a9e1.tar.bz2
pcre: update to 8.41
Diffstat (limited to 'abs/core/pcre')
-rw-r--r--abs/core/pcre/01-CVE-2016-1283.patch18
-rw-r--r--abs/core/pcre/PKGBUILD18
2 files changed, 8 insertions, 28 deletions
diff --git a/abs/core/pcre/01-CVE-2016-1283.patch b/abs/core/pcre/01-CVE-2016-1283.patch
deleted file mode 100644
index 2c2dad2..0000000
--- a/abs/core/pcre/01-CVE-2016-1283.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: pcre_compile.c
-===================================================================
---- a/pcre_compile.c (revision 1635)
-+++ b/pcre_compile.c (revision 1636)
-@@ -7311,7 +7311,12 @@
- so far in order to get the number. If the name is not found, leave
- the value of recno as 0 for a forward reference. */
-
-- else
-+ /* This patch (removing "else") fixes a problem when a reference is
-+ to multiple identically named nested groups from within the nest.
-+ Once again, it is not the "proper" fix, and it results in an
-+ over-allocation of memory. */
-+
-+ /* else */
- {
- ng = cd->named_groups;
- for (i = 0; i < cd->names_found; i++, ng++)
diff --git a/abs/core/pcre/PKGBUILD b/abs/core/pcre/PKGBUILD
index e578d33..0b25d9f 100644
--- a/abs/core/pcre/PKGBUILD
+++ b/abs/core/pcre/PKGBUILD
@@ -5,19 +5,17 @@
# Contributor: John Proctor <jproctor@prium.net>
pkgname=pcre
-pkgver=8.38
-pkgrel=3
+pkgver=8.41
+pkgrel=1
pkgdesc='A library that implements Perl 5-style regular expressions'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://www.pcre.org/'
license=('BSD')
depends=('gcc-libs' 'readline' 'zlib' 'bzip2' 'bash')
validpgpkeys=('45F68D54BBE23FB3039B46E59766E084FB0F43D8') # Philip Hazel
-source=("ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/$pkgname-$pkgver.tar.bz2"{,.sig}
- '01-CVE-2016-1283.patch')
-md5sums=('00aabbfe56d5a48b270f999b508c5ad2'
- 'SKIP'
- '722aba6455a3f0240eaa22289f0176a0')
+source=("https://ftp.pcre.org/pub/pcre/$pkgname-$pkgver.tar.bz2"{,.sig})
+md5sums=('c160d22723b1670447341b08c58981c1'
+ 'SKIP')
prepare() {
cd $pkgname-$pkgver
@@ -25,8 +23,8 @@ prepare() {
local filename
for filename in "${source[@]}"; do
if [[ "$filename" =~ \.patch$ ]]; then
- msg2 "Applying patch $filename"
- patch -p1 -N -i "$srcdir/$filename"
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
fi
done
: