summaryrefslogtreecommitdiffstats
path: root/abs/core/pcre
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 17:53:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 17:53:44 (GMT)
commit4cf4de0fd9895bae9713f28ab85983c3900ca0fc (patch)
tree85c3f4651adf6405118f6a98acd1cd66792810bd /abs/core/pcre
parent25b32097c819d3812d466fde64e141cb1f77443c (diff)
downloadlinhes_pkgbuild-4cf4de0fd9895bae9713f28ab85983c3900ca0fc.zip
linhes_pkgbuild-4cf4de0fd9895bae9713f28ab85983c3900ca0fc.tar.gz
linhes_pkgbuild-4cf4de0fd9895bae9713f28ab85983c3900ca0fc.tar.bz2
pcre 8.31
Diffstat (limited to 'abs/core/pcre')
-rw-r--r--abs/core/pcre/PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/abs/core/pcre/PKGBUILD b/abs/core/pcre/PKGBUILD
index 83dfe94..08a9117 100644
--- a/abs/core/pcre/PKGBUILD
+++ b/abs/core/pcre/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id$
+# $Id: PKGBUILD 163492 2012-07-13 12:30:53Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net>
pkgname=pcre
-pkgver=8.12
+pkgver=8.31
pkgrel=1
pkgdesc="A library that implements Perl 5-style regular expressions"
arch=('i686' 'x86_64')
@@ -12,25 +12,27 @@ url="http://www.pcre.org/"
license=('BSD')
depends=('gcc-libs')
options=('!libtool')
-source=(ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('f14a9fef3c92f3fc6c5ac92d7a2c7eb3')
-sha1sums=('2219b372bff53ee29a7e44ecf5977ad15df01cea')
+source=(ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${pkgname}-${pkgver}.tar.bz2{,.sig})
+md5sums=('1c9a276af932b5599157f96e945391f0'
+ '873bcd2cd9f1e0aa1e28e256b3e31506')
build() {
cd "${srcdir}"/${pkgname}-${pkgver}
+
[ "${CARCH}" = "x86_64" ] && export CFLAGS="${CFLAGS} -fPIC"
- ./configure --prefix=/usr --enable-utf8 --enable-unicode-properties
+ ./configure --prefix=/usr --enable-pcre16 --enable-jit \
+ --enable-utf8 --enable-unicode-properties
make
}
+check() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make check
+}
+
package() {
cd "${srcdir}"/${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
- # grep uses pcre, so we need the libs in /lib
- install -dm755 "${pkgdir}"/lib
- mv "${pkgdir}"/usr/lib/libpcre.so.* "${pkgdir}"/lib/
- ln -sf /lib/libpcre.so.0 "${pkgdir}"/usr/lib/libpcre.so
-
install -Dm644 LICENCE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}