summaryrefslogtreecommitdiffstats
path: root/abs/core/pcre
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-08-04 22:54:10 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-08-04 22:54:10 (GMT)
commit66be0cdc0ed7d5802527e7228adee01f4a17127d (patch)
tree7b5a690c76b813fe240200848cfdf240723fc8b1 /abs/core/pcre
parent6c3099aff3af9a3b217a5eeb12336c0dc09b8652 (diff)
downloadlinhes_pkgbuild-66be0cdc0ed7d5802527e7228adee01f4a17127d.zip
linhes_pkgbuild-66be0cdc0ed7d5802527e7228adee01f4a17127d.tar.gz
linhes_pkgbuild-66be0cdc0ed7d5802527e7228adee01f4a17127d.tar.bz2
pcre: Bump to latest. Dep of glib2
Diffstat (limited to 'abs/core/pcre')
-rw-r--r--abs/core/pcre/ChangeLog40
-rw-r--r--abs/core/pcre/PKGBUILD16
-rw-r--r--abs/core/pcre/libpcre-7.7-buffer-overflow.patch16
3 files changed, 8 insertions, 64 deletions
diff --git a/abs/core/pcre/ChangeLog b/abs/core/pcre/ChangeLog
deleted file mode 100644
index cdff568..0000000
--- a/abs/core/pcre/ChangeLog
+++ /dev/null
@@ -1,40 +0,0 @@
-2010-03-24 Eric Belanger <eric@archlinux.org>
-
- * pcre 8.02-1
- * Upstream update
-
-2010-01-23 Eric Belanger <eric@archlinux.org>
-
- * pcre 8.01-1
- * Upstream update
-
-2009-10-26 Eric Belanger <eric@archlinux.org>
-
- * pcre 8.00-1
- * Upstream update
-
-2009-04-13 Eric Belanger <eric@archlinux.org>
-
- * pcre 7.9-1
- * Upstream update
-
-2008-10-19 Eric Belanger <eric@archlinux.org>
-
- * Updated url
-
-2008-09-05 Eric Belanger <eric@archlinux.org>
-
- * pcre 7.8-1
- * Upstream update
- * Fixed license
-
-2008-07-07 Eric Belanger <eric@archlinux.org>
-
- * pcre 7.7-2
- * Added libpcre-7.7-buffer-overflow.patch to fix buffer overflow (close FS#10845)
-
-2008-05-10 Eric Belanger <eric@archlinux.org>
-
- * pcre 7.7-1
- * Upstream update
- * Added ChangeLog
diff --git a/abs/core/pcre/PKGBUILD b/abs/core/pcre/PKGBUILD
index d31e23c..83dfe94 100644
--- a/abs/core/pcre/PKGBUILD
+++ b/abs/core/pcre/PKGBUILD
@@ -1,20 +1,20 @@
-# $Id: PKGBUILD 84661 2010-07-03 04:01:39Z allan $
+# $Id$
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net>
pkgname=pcre
-pkgver=8.10
+pkgver=8.12
pkgrel=1
pkgdesc="A library that implements Perl 5-style regular expressions"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64')
url="http://www.pcre.org/"
license=('BSD')
depends=('gcc-libs')
options=('!libtool')
source=(ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('780867a700e9d4e4b9cb47aa5453e4b2')
-sha1sums=('8b345da0f835b2caabff071b0b5bab40564652be')
+md5sums=('f14a9fef3c92f3fc6c5ac92d7a2c7eb3')
+sha1sums=('2219b372bff53ee29a7e44ecf5977ad15df01cea')
build() {
cd "${srcdir}"/${pkgname}-${pkgver}
@@ -26,11 +26,11 @@ build() {
package() {
cd "${srcdir}"/${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
-
+
# grep uses pcre, so we need the libs in /lib
install -dm755 "${pkgdir}"/lib
mv "${pkgdir}"/usr/lib/libpcre.so.* "${pkgdir}"/lib/
- ln -sf ../../lib/libpcre.so.0 "${pkgdir}"/usr/lib/libpcre.so
-
+ ln -sf /lib/libpcre.so.0 "${pkgdir}"/usr/lib/libpcre.so
+
install -Dm644 LICENCE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}
diff --git a/abs/core/pcre/libpcre-7.7-buffer-overflow.patch b/abs/core/pcre/libpcre-7.7-buffer-overflow.patch
deleted file mode 100644
index a27987f..0000000
--- a/abs/core/pcre/libpcre-7.7-buffer-overflow.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -NrU5 pcre-7.7.orig/pcre_compile.c pcre-7.7/pcre_compile.c
---- pcre-7.7.orig/pcre_compile.c 2008-06-18 17:08:49.000000000 +0200
-+++ pcre-7.7/pcre_compile.c 2008-06-18 17:11:04.000000000 +0200
-@@ -4929,11 +4929,11 @@
- {
- if (code == cd->start_code + 1 + LINK_SIZE &&
- (lengthptr == NULL || *lengthptr == 2 + 2*LINK_SIZE))
- {
- cd->external_options = newoptions;
-- options = newoptions;
-+ options = *optionsptr = newoptions;
- }
- else
- {
- if ((options & PCRE_IMS) != (newoptions & PCRE_IMS))
- {