summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-algorithm-diff/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/perl_modules/perl-algorithm-diff/PKGBUILD
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/perl_modules/perl-algorithm-diff/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-algorithm-diff/PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/abs/core/perl_modules/perl-algorithm-diff/PKGBUILD b/abs/core/perl_modules/perl-algorithm-diff/PKGBUILD
index d185772..864421a 100644
--- a/abs/core/perl_modules/perl-algorithm-diff/PKGBUILD
+++ b/abs/core/perl_modules/perl-algorithm-diff/PKGBUILD
@@ -1,20 +1,27 @@
-# This PKGBUILD was autocreated. See http://xtermin.us/archperl/ for details
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Charles Mauch <cmauch@gmail.com>
+
pkgname=perl-algorithm-diff
-pkgver=1.1902
-pkgrel=4
+pkgver=1.1903
+pkgrel=3
pkgdesc="Perl/CPAN Module Algorithm::Diff : Diff also Longest Common Subsequence"
-arch=("i686" "x86_64")
-url="http://search.cpan.org/TYEMQ/Algorithm-Diff"
-license=("GPL" "Artistic")
-source=("http://www.cpan.org/authors/id/T/TY/TYEMQ/Algorithm-Diff-1.1902.tar.gz")
-md5sums=("ff3e17ae485f8adfb8857b183991fbce")
-groups=('shepherd-dep')
+arch=("any")
+url="http://search.cpan.org/dist/Algorithm-Diff"
+license=("GPL" "PerlArtistic")
+depends=(perl)
+source=("http://search.cpan.org/CPAN/authors/id/T/TY/TYEMQ/Algorithm-Diff-$pkgver.tar.gz")
+md5sums=('0e8add21a641b8d66436df0c2024bf3b')
+
build() {
- cd $startdir/src/Algorithm-Diff-1.1902
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make pure_install doc_install DESTDIR=$startdir/pkg || return 1
- find $startdir/pkg -name '.packlist' -delete
- find $startdir/pkg -name '*.pod' -delete
+ cd "$srcdir"/Algorithm-Diff-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir"/Algorithm-Diff-$pkgver
+ make pure_install doc_install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
}