summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-class-std-fast/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-04-18 17:35:34 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-04-18 17:35:34 (GMT)
commita3e950053d847e719d489c13064b6c165425385c (patch)
treefccd4ec9f53e519563c0cfd25833cd8c3caaaa20 /abs/core/perl_modules/perl-class-std-fast/PKGBUILD
parentbd44be589a2626bd26a7f31b23c2358fb74e5c95 (diff)
parent0a8de86de9f21f7877075ac2800254239ae84a81 (diff)
downloadlinhes_pkgbuild-a3e950053d847e719d489c13064b6c165425385c.zip
linhes_pkgbuild-a3e950053d847e719d489c13064b6c165425385c.tar.gz
linhes_pkgbuild-a3e950053d847e719d489c13064b6c165425385c.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/perl_modules/perl-class-std-fast/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-class-std-fast/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-class-std-fast/PKGBUILD b/abs/core/perl_modules/perl-class-std-fast/PKGBUILD
new file mode 100644
index 0000000..71878e6
--- /dev/null
+++ b/abs/core/perl_modules/perl-class-std-fast/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname='perl-class-std-fast'
+pkgver='0.0.8'
+pkgrel='1'
+pkgdesc="Class::Std::Fast allows you to use the beautiful API of Class::Std in a faster way than Class::Std"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl' 'perl-class-std')
+makedepends=()
+url='http://search.cpan.org/~acid/Class-Std-Fast/'
+source=('http://search.cpan.org/CPAN/authors/id/A/AC/ACID/Class-Std-Fast-v0.0.8.tar.gz')
+_distdir="Class-Std-Fast-v0.0.8"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+md5sums=('d06d084cb84f295b0aabf2eee78ef746')