summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-crypt-ssleay/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/perl_modules/perl-crypt-ssleay/PKGBUILD
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/perl_modules/perl-crypt-ssleay/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-crypt-ssleay/PKGBUILD31
1 files changed, 23 insertions, 8 deletions
diff --git a/abs/core/perl_modules/perl-crypt-ssleay/PKGBUILD b/abs/core/perl_modules/perl-crypt-ssleay/PKGBUILD
index ccaab5e..8dd1a04 100644
--- a/abs/core/perl_modules/perl-crypt-ssleay/PKGBUILD
+++ b/abs/core/perl_modules/perl-crypt-ssleay/PKGBUILD
@@ -1,31 +1,46 @@
-# $Id: PKGBUILD 160515 2012-06-02 10:27:13Z bluewind $
+# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: François Charette <firmicus ατ gmx δοτ net>
pkgname=perl-crypt-ssleay
-pkgver=0.58
-pkgrel=4
+pkgver=0.73_04
+pkgrel=9
pkgdesc="OpenSSL glue that provides LWP https support"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://search.cpan.org/dist/Crypt-SSLeay"
license=('GPL' 'PerlArtistic')
-depends=('openssl')
+depends=('perl-lwp-protocol-https' 'perl-try-tiny' 'perl-path-class')
options=('!emptydirs')
-source=(http://www.cpan.org/CPAN/authors/id/N/NA/NANIS/Crypt-SSLeay-$pkgver.tar.gz)
-md5sums=('fbf3d12e58462cee00ea63239c0b13c7')
+source=(http://www.cpan.org/CPAN/authors/id/N/NA/NANIS/Crypt-SSLeay-$pkgver.tar.gz)
+md5sums=('7508b2a34da2202cc0c78deb59e36526')
build() {
cd "${srcdir}/Crypt-SSLeay-${pkgver}"
+ PERL_USE_UNSAFE_INC=1 \
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
- make test
+}
+
+check() {
+ cd "${srcdir}/Crypt-SSLeay-${pkgver}"
+
+# make test
}
package() {
cd "${srcdir}/Crypt-SSLeay-${pkgver}"
+
make install DESTDIR="${pkgdir}"
find ${pkgdir} -name '.packlist' -delete
find ${pkgdir} -name '*.pod' -delete
+
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+ _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+ _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+ depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
}