summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-datetime-format-iso8601
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/core/perl_modules/perl-datetime-format-iso8601
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core/perl_modules/perl-datetime-format-iso8601')
-rw-r--r--abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD b/abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD
new file mode 100644
index 0000000..360b88a
--- /dev/null
+++ b/abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Lukas Fleischer <archlinux at cryptocrack dot de>
+
+pkgname=perl-datetime-format-iso8601
+pkgver=0.07
+pkgrel=1
+pkgdesc="Parses ISO8601 formats."
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/dist/DateTime-Format-ISO8601/"
+license=('PerlArtistic')
+depends=('perl-datetime-format-builder>=0.770.0' 'perl-datetime>=0.18')
+#makedepends=('perl-module-build>=0.350.0')
+optdepends=('perl-file-find-rule'
+ 'perl-test-distribution'
+ 'perl-test-pod')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/J/JH/JHOBLITT/DateTime-Format-ISO8601-$pkgver.tar.gz")
+md5sums=('debb51180d0318ae09cad01c544a1d7d')
+
+build() {
+ cd $srcdir/DateTime-Format-ISO8601-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR="${pkgdir}" || return 1
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+}