summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD b/abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD
new file mode 100644
index 0000000..5f2d8de
--- /dev/null
+++ b/abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+# Contributor: Francois Charette <firmicus@gmx.net>
+
+pkgname=perl-datetime-format-strptime
+_pkgname=DateTime-Format-Strptime
+pkgver=1.0900
+pkgrel=1
+pkgdesc="DateTime::Format::Strptime - Parse and format strp and strf time patterns"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~RICKM/${_pkgname}"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0' 'perl-datetime')
+options=(!emptydirs)
+
+source=(http://www.cpan.org/authors/id/R/RI/RICKM/${_pkgname}-$pkgver.tgz)
+md5sums=('f84e3e11b2948ca0fc2848b9c123e473')
+
+build() {
+ cd $srcdir/${_pkgname}-$pkgver
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+
+ make || return 1
+ make install DESTDIR=$pkgdir || return 1
+
+ find $pkgdir -name perllocal.pod -delete
+ find $pkgdir -name .packlist -delete
+}