summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-device-serialport/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-01 20:53:34 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-01 20:53:34 (GMT)
commitd0c99337b3abdb67d6d8bd1b5074fad2f2261988 (patch)
treeee4d0df01ff42210d1bce0d65e24e4389e63007b /abs/core/perl_modules/perl-device-serialport/PKGBUILD
parent427e01961c6ed50ac990f5327d00a7e42c3a2a69 (diff)
downloadlinhes_pkgbuild-d0c99337b3abdb67d6d8bd1b5074fad2f2261988.zip
linhes_pkgbuild-d0c99337b3abdb67d6d8bd1b5074fad2f2261988.tar.gz
linhes_pkgbuild-d0c99337b3abdb67d6d8bd1b5074fad2f2261988.tar.bz2
Added perl_modules for zoneminder:
perl-device-serialport perl-expect perl-io-tty per-net-sftp-foreign perl-time-modules refs#857
Diffstat (limited to 'abs/core/perl_modules/perl-device-serialport/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-device-serialport/PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/abs/core/perl_modules/perl-device-serialport/PKGBUILD b/abs/core/perl_modules/perl-device-serialport/PKGBUILD
index d1341c8..7f0ba54 100644
--- a/abs/core/perl_modules/perl-device-serialport/PKGBUILD
+++ b/abs/core/perl_modules/perl-device-serialport/PKGBUILD
@@ -1,29 +1,25 @@
-# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# $Id: PKGBUILD 71775 2012-06-02 10:30:18Z bluewind $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Ross melin <rdmelin@gmail.com>
-# Required by zoneminder
-
pkgname=perl-device-serialport
pkgver=1.04
-pkgrel=2
+pkgrel=4
pkgdesc="POSIX clone of Win32::SerialPort"
arch=('i686' 'x86_64')
-url="http://search.cpan.org/~COOK/Device-SerialPort"
+url="http://search.cpan.org/dist/Device-SerialPort"
license=('GPL' 'PerlArtistic')
+depends=('perl')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/C/CO/COOK/Device-SerialPort-$pkgver.tar.gz)
+source=(http://www.cpan.org/authors/id/C/CO/COOK/Device-SerialPort-$pkgver.tar.gz)
md5sums=('82c698151f934eb28c65d1838cee7d9e')
build() {
- cd $startdir/src/Device-SerialPort-$pkgver
+ cd $srcdir/Device-SerialPort-$pkgver
eval `perl -V:archname`
- PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
- INSTALLDIRS=vendor || return 1
-
- /usr/bin/make || return 1
- /usr/bin/make DESTDIR=$startdir/pkg install || return 1
- /usr/bin/find $startdir/pkg -name '.packlist' -delete
- /usr/bin/find $startdir/pkg -name '*.pod' -delete
+ PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make DESTDIR=$pkgdir install
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
}
-
-# vim:set ts=2 sw=2 et: