summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-error/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
commitad58e3033f6bb5137b8dcb0e7eca12d50d888402 (patch)
tree9321335a68173bc3e4c1d237c19c8880411fa676 /abs/core/perl_modules/perl-error/PKGBUILD
parent998faf16b1b62493b39aa13b3cb53dfac266ef4c (diff)
parent9709ca528ca5dfbdb6ec6ea283ac6670e8f33b9d (diff)
downloadlinhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.zip
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.gz
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Conflicts: abs/core/tzdata/PKGBUILD
Diffstat (limited to 'abs/core/perl_modules/perl-error/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-error/PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/abs/core/perl_modules/perl-error/PKGBUILD b/abs/core/perl_modules/perl-error/PKGBUILD
index c804210..2a4437c 100644
--- a/abs/core/perl_modules/perl-error/PKGBUILD
+++ b/abs/core/perl_modules/perl-error/PKGBUILD
@@ -1,27 +1,35 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id$
# Maintainer: Dale Blount <dale@archlinux.org>
# Contributor: Dale Blount <dale@archlinux.org>
pkgname=perl-error
_realname=Error
-pkgver=0.17015
-pkgrel=1
+pkgver=0.17016
+pkgrel=2
pkgdesc="Perl/CPAN Error module - Error/exception handling in an OO-ish way"
url="http://search.cpan.org/dist/${_realname}/"
-arch=(i686 x86_64)
+arch=(any)
license=('PerlArtistic' 'GPL')
depends=('perl>=5.10.0')
options=('!emptydirs')
source=(http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/${_realname}-${pkgver}.tar.gz)
+md5sums=('eedcd3c6970568dd32092b5334328eff')
build() {
- cd ${startdir}/src/${_realname}-${pkgver}
+ cd ${srcdir}/${_realname}-${pkgver}
# install module in vendor directories.
- perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=${startdir}/pkg || return 1
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make test
+}
+
+package() {
+ cd ${srcdir}/${_realname}-${pkgver}
+
+ make install DESTDIR=${pkgdir}
# remove perllocal.pod and .packlist
- find ${startdir}/pkg -name perllocal.pod -delete
- find ${startdir}/pkg -name .packlist -delete
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
}
+