summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-io-tty/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-01 20:53:34 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-01 20:53:34 (GMT)
commitd0c99337b3abdb67d6d8bd1b5074fad2f2261988 (patch)
treeee4d0df01ff42210d1bce0d65e24e4389e63007b /abs/core/perl_modules/perl-io-tty/PKGBUILD
parent427e01961c6ed50ac990f5327d00a7e42c3a2a69 (diff)
downloadlinhes_pkgbuild-d0c99337b3abdb67d6d8bd1b5074fad2f2261988.zip
linhes_pkgbuild-d0c99337b3abdb67d6d8bd1b5074fad2f2261988.tar.gz
linhes_pkgbuild-d0c99337b3abdb67d6d8bd1b5074fad2f2261988.tar.bz2
Added perl_modules for zoneminder:
perl-device-serialport perl-expect perl-io-tty per-net-sftp-foreign perl-time-modules refs#857
Diffstat (limited to 'abs/core/perl_modules/perl-io-tty/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-io-tty/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-io-tty/PKGBUILD b/abs/core/perl_modules/perl-io-tty/PKGBUILD
new file mode 100644
index 0000000..540af17
--- /dev/null
+++ b/abs/core/perl_modules/perl-io-tty/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 71803 2012-06-02 10:31:14Z bluewind $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Charles Mauch <cmauch@gmail.com>
+
+pkgname=perl-io-tty
+pkgver=1.10
+pkgrel=2
+pkgdesc="Provide an interface to TTYs and PTYs"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/dist/IO-Tty/"
+license=("GPL" "PerlArtistic")
+depends=('glibc')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/IO-Tty-$pkgver.tar.gz")
+md5sums=('46baec86a145e57f0ec661fa412b097c')
+
+build() {
+ cd $srcdir/IO-Tty-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+package(){
+ cd $srcdir/IO-Tty-$pkgver
+ make install DESTDIR=$pkgdir
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}