summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-net-smtp-ssl
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/perl_modules/perl-net-smtp-ssl
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/perl_modules/perl-net-smtp-ssl')
-rw-r--r--abs/core/perl_modules/perl-net-smtp-ssl/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-net-smtp-ssl/PKGBUILD b/abs/core/perl_modules/perl-net-smtp-ssl/PKGBUILD
new file mode 100644
index 0000000..443868e
--- /dev/null
+++ b/abs/core/perl_modules/perl-net-smtp-ssl/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id$
+# Maintainer: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
+
+pkgname=perl-net-smtp-ssl
+pkgver=1.04
+pkgrel=3
+pkgdesc="SSL support for Net::SMTP"
+arch=(any)
+url="http://search.cpan.org/dist/Net-SMTP-SSL/"
+license=('GPL' 'PerlArtistic')
+depends=('perl-io-socket-ssl')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Net-SMTP-SSL-$pkgver.tar.gz")
+sha256sums=('7b29c45add19d3d5084b751f7ba89a8e40479a446ce21cfd9cc741e558332a00')
+
+package() {
+ cd "${srcdir}/Net-SMTP-SSL-${pkgver}"
+ # Install module into the vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make DESTDIR="$pkgdir" install || return 1
+
+ # Remove .packlist and perllocal.pod files.
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name 'perllocal.pod' -delete
+}