summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-shell
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-13 19:12:35 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-13 19:12:35 (GMT)
commitc1d58b08c367d9b8340e3a7fbd77b29ed2219963 (patch)
treee965a2cf7352d8c2a1188a1af39b022b40ccb570 /abs/core/perl_modules/perl-shell
parent64ad3bbea8f3e810267c71dec78a00bfd3f00672 (diff)
downloadlinhes_pkgbuild-c1d58b08c367d9b8340e3a7fbd77b29ed2219963.zip
linhes_pkgbuild-c1d58b08c367d9b8340e3a7fbd77b29ed2219963.tar.gz
linhes_pkgbuild-c1d58b08c367d9b8340e3a7fbd77b29ed2219963.tar.bz2
perl-shell: 0.72 shell was removed from perl_core and moved to it's own module. Not for sure why but it was
Diffstat (limited to 'abs/core/perl_modules/perl-shell')
-rw-r--r--abs/core/perl_modules/perl-shell/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-shell/PKGBUILD b/abs/core/perl_modules/perl-shell/PKGBUILD
new file mode 100644
index 0000000..31e5278
--- /dev/null
+++ b/abs/core/perl_modules/perl-shell/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: graysky <graysky AT archlnux DOT us>
+
+pkgname=perl-shell
+_realname=Shell
+pkgver=0.72
+_pkgver=0.72_01
+pkgrel=2
+pkgdesc="Run shell commands transparently within perl."
+arch=(any)
+license=('PerlArtistic')
+url="http://search.cpan.org/dist/${_realname}/"
+depends=('perl>=5.011')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/F/FE/FERREIRA/${_realname}-${_pkgver}.tar.gz)
+sha256sums=('823c044e668239be0ac96d0006f5fc9646b8a9a8adfd5f58f2dcd297e875106f')
+
+build() {
+ cd ${srcdir}/${_realname}-${_pkgver}
+ perl Makefile.PL
+ make
+}
+
+package() {
+ cd ${srcdir}/${_realname}-${_pkgver}
+ make install DESTDIR=${pkgdir}
+}