summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-test-requires/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 17:54:22 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 17:54:22 (GMT)
commitff0f7cee2dc2b420e257313fef663a3f78bbc800 (patch)
tree7af473b8667e5c685144e8123934878b79896412 /abs/core/perl_modules/perl-test-requires/PKGBUILD
parent16a043fed17ea05b6d6ca012ff09b71008562790 (diff)
downloadlinhes_pkgbuild-ff0f7cee2dc2b420e257313fef663a3f78bbc800.zip
linhes_pkgbuild-ff0f7cee2dc2b420e257313fef663a3f78bbc800.tar.gz
linhes_pkgbuild-ff0f7cee2dc2b420e257313fef663a3f78bbc800.tar.bz2
perl_modules: updated to many to list
Diffstat (limited to 'abs/core/perl_modules/perl-test-requires/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-test-requires/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-test-requires/PKGBUILD b/abs/core/perl_modules/perl-test-requires/PKGBUILD
new file mode 100644
index 0000000..c7de2ab
--- /dev/null
+++ b/abs/core/perl_modules/perl-test-requires/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Justin Davis <jrcd83@gmail.com>
+
+pkgname='perl-test-requires'
+pkgver='0.06'
+pkgrel='1'
+pkgdesc="Checks to see if the module can be loaded"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+url='http://search.cpan.org/dist/Test-Requires'
+source=("http://search.cpan.org/CPAN/authors/id/T/TO/TOKUHIROM/Test-Requires-$pkgver.tar.gz")
+md5sums=('6ce0da3cceadb6420d4c3c5bb69f64db')
+
+build() {
+ cd "${srcdir}/Test-Requires-$pkgver"
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ perl Makefile.PL
+ make
+ make test
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}