summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-30 20:27:02 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-30 20:27:02 (GMT)
commit024a4f7c6c6bf013c30dc6a21e644f8d98e3f20a (patch)
treeecbcfaf54cae3ca0d44c16059b6c08db74fdcf20 /abs/core/perl_modules
parentbccdf74d6a37c3e06d59ac7a0046b1d6b88a5661 (diff)
downloadlinhes_pkgbuild-024a4f7c6c6bf013c30dc6a21e644f8d98e3f20a.zip
linhes_pkgbuild-024a4f7c6c6bf013c30dc6a21e644f8d98e3f20a.tar.gz
linhes_pkgbuild-024a4f7c6c6bf013c30dc6a21e644f8d98e3f20a.tar.bz2
perl-datetime-format-strptime: update to 1.75
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-datetime-format-strptime/ChangeLog7
-rw-r--r--abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD44
2 files changed, 23 insertions, 28 deletions
diff --git a/abs/core/perl_modules/perl-datetime-format-strptime/ChangeLog b/abs/core/perl_modules/perl-datetime-format-strptime/ChangeLog
deleted file mode 100644
index 46b7684..0000000
--- a/abs/core/perl_modules/perl-datetime-format-strptime/ChangeLog
+++ /dev/null
@@ -1,7 +0,0 @@
-2009-02-27 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
-
- * 1.0900-1 :
- Adopted the PKGBUILD
- Modified the PKGBUILD to match new PKGBUILD-perl.proto
- Added missing dep perl-datetime
- Added a ChangeLog
diff --git a/abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD b/abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD
index 5f2d8de..0ae3df0 100644
--- a/abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD
+++ b/abs/core/perl_modules/perl-datetime-format-strptime/PKGBUILD
@@ -1,28 +1,30 @@
-# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
-# Contributor: Francois Charette <firmicus@gmx.net>
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Caleb Cushing <xenoterracide@gmail.com>
pkgname=perl-datetime-format-strptime
-_pkgname=DateTime-Format-Strptime
-pkgver=1.0900
+pkgver=1.75
pkgrel=1
-pkgdesc="DateTime::Format::Strptime - Parse and format strp and strf time patterns"
-arch=('i686' 'x86_64')
-url="http://search.cpan.org/~RICKM/${_pkgname}"
-license=('GPL' 'PerlArtistic')
-depends=('perl>=5.10.0' 'perl-datetime')
-options=(!emptydirs)
-
-source=(http://www.cpan.org/authors/id/R/RI/RICKM/${_pkgname}-$pkgver.tgz)
-md5sums=('f84e3e11b2948ca0fc2848b9c123e473')
+pkgdesc="Parse and Format DateTimes using Strptime"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-datetime>=0.72' 'perl-datetime-locale>=0.45'
+ 'perl-datetime-timezone>=0.79' 'perl-params-validate>=0.64'
+ 'perl-package-deprecationmanager')
+url="http://search.cpan.org/dist/DateTime-Format-Strptime"
+source=("http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Format-Strptime-${pkgver}.tar.gz")
+sha256sums=('4fcfb2ac4f79d7ff2855a405f39050d2ea691ee098ce54ede8af79c8d6ab3c19')
build() {
- cd $srcdir/${_pkgname}-$pkgver
-
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
-
- make || return 1
- make install DESTDIR=$pkgdir || return 1
+ export PERL_MM_USE_DEFAULT=1
+ cd "${srcdir}/DateTime-Format-Strptime-${pkgver}"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
- find $pkgdir -name perllocal.pod -delete
- find $pkgdir -name .packlist -delete
+package() {
+ cd "${srcdir}/DateTime-Format-Strptime-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}