summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-31 18:07:04 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-31 18:07:04 (GMT)
commit04e54f944f30a52c0cb36b36c3da207341a7d45e (patch)
tree9bfaa7fc1edef53b336fba8cbb7f41db61d1a123 /abs/core/perl_modules
parent58c33678ab8d788f08042aa047797d94555d13f3 (diff)
downloadlinhes_pkgbuild-04e54f944f30a52c0cb36b36c3da207341a7d45e.zip
linhes_pkgbuild-04e54f944f30a52c0cb36b36c3da207341a7d45e.tar.gz
linhes_pkgbuild-04e54f944f30a52c0cb36b36c3da207341a7d45e.tar.bz2
perl-x10: rebuild
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-x10/PKGBUILD64
1 files changed, 42 insertions, 22 deletions
diff --git a/abs/core/perl_modules/perl-x10/PKGBUILD b/abs/core/perl_modules/perl-x10/PKGBUILD
index 51283d5..bfcfaa1 100644
--- a/abs/core/perl_modules/perl-x10/PKGBUILD
+++ b/abs/core/perl_modules/perl-x10/PKGBUILD
@@ -1,30 +1,50 @@
-# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
-# Contributor: Ross melin <rdmelin@gmail.com>
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.29
-# Required by zoneminder
-
-pkgname=perl-x10
-pkgver=0.03
-pkgrel=2
-pkgdesc="X10"
-arch=('i686' 'x86_64')
-url="http://search.cpan.org/~ROBF/X10"
-license=('GPL' 'PerlArtistic')
-depends=('perl-astro-suntime>=0.01' 'perl-device-serialport' 'perl-time-modules')
+pkgname='perl-x10'
+pkgver='0.03'
+pkgrel='3'
+pkgdesc="Manage X10 devices in Perl"
+arch=('any')
+license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/R/RO/ROBF/X10-$pkgver.tar.gz)
+depends=('perl-astro-suntime>=0.01' 'perl-device-serialport' 'perl-time-modules')
+makedepends=()
+url='http://search.mcpan.org/dist/X10'
+source=('http://search.mcpan.org/CPAN/authors/id/R/RO/ROBF/X10-0.03.tar.gz')
md5sums=('056b3d98fab545865148b948de6784c7')
+sha512sums=('6ed2b9526732dc5f704ceb94f3a9abb51c208aabb6f127480046ce1f01ecf763e4de2dcb5bf52ef598831dbd5ba78ff9d108238001070076b0cc05c7681dea2f')
+_distdir="X10-0.03"
build() {
- cd $startdir/src/X10-$pkgver
- eval `perl -V:archname`
- PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
- INSTALLDIRS=vendor || return 1
-
- /usr/bin/make || return 1
- /usr/bin/make DESTDIR=$startdir/pkg install || return 1
- /usr/bin/find $startdir/pkg -name '.packlist' -delete
- /usr/bin/find $startdir/pkg -name '*.pod' -delete
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
# vim:set ts=2 sw=2 et: