summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-31 16:04:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-31 16:04:23 (GMT)
commit07c0d930969490efc361c5c061e9e6066a2a091e (patch)
tree1663a7e69ce548859ed8d98793dd889222754ff1 /abs/core/perl_modules
parent42ebda4dd776f2b8f1dc5faf6af96780f999ec0a (diff)
downloadlinhes_pkgbuild-07c0d930969490efc361c5c061e9e6066a2a091e.zip
linhes_pkgbuild-07c0d930969490efc361c5c061e9e6066a2a091e.tar.gz
linhes_pkgbuild-07c0d930969490efc361c5c061e9e6066a2a091e.tar.bz2
perl-php-serialization: update to 0.34
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-php-serialization/PKGBUILD66
1 files changed, 43 insertions, 23 deletions
diff --git a/abs/core/perl_modules/perl-php-serialization/PKGBUILD b/abs/core/perl_modules/perl-php-serialization/PKGBUILD
index 428ee8e..d395dc9 100644
--- a/abs/core/perl_modules/perl-php-serialization/PKGBUILD
+++ b/abs/core/perl_modules/perl-php-serialization/PKGBUILD
@@ -1,30 +1,50 @@
-# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
-# Contributor: Ross melin <rdmelin@gmail.com>
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
-# Required by zoneminder
-
-pkgname=perl-php-serialization
-pkgver=0.27
-pkgrel=2
-pkgdesc="PHP::Serialization"
-arch=('i686' 'x86_64')
-url="http://search.cpan.org/~php-serialization/PHP-Serialization"
-license=('GPL' 'PerlArtistic')
-depends=('perl')
+pkgname='perl-php-serialization'
+pkgver='0.34'
+pkgrel='1'
+pkgdesc="simple flexible means of converting the output of PHP's serialize() into the equivalent Perl memory structure, and vice versa."
+arch=('any')
+license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/J/JB/JBROWN/php-serialization/PHP-Serialization-$pkgver.tar.gz)
-md5sums=('2fb3f63071c5c2119b4eebe39b329684')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/PHP-Serialization'
+source=('http://search.cpan.org/CPAN/authors/id/B/BO/BOBTFISH/PHP-Serialization-0.34.tar.gz')
+md5sums=('333af0848ad79931875a35cc61dc22e0')
+sha512sums=('72218973f21ab71419751cf818e6bd998235aa74bf8ae60ec4a6080ba169d0d7fcefde4f433ce3f6f30ed3084a651deb8aa3a5dd818fc6ebf3fb6188def4efe7')
+_distdir="PHP-Serialization-0.34"
build() {
- cd $startdir/src/PHP-Serialization-$pkgver
- eval `perl -V:archname`
- PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
- INSTALLDIRS=vendor || return 1
-
- /usr/bin/make || return 1
- /usr/bin/make DESTDIR=$startdir/pkg install || return 1
- /usr/bin/find $startdir/pkg -name '.packlist' -delete
- /usr/bin/find $startdir/pkg -name '*.pod' -delete
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
# vim:set ts=2 sw=2 et: