summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-31 17:59:08 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-31 17:59:08 (GMT)
commit1554ecd8c6978862d012c4fe35295e660161aed1 (patch)
treecf48f9a2d25b37eae672495191bc14fa8c12c277 /abs/core/perl_modules
parent5b3c935a6abe0d6aab74abbc64428e95174ac782 (diff)
downloadlinhes_pkgbuild-1554ecd8c6978862d012c4fe35295e660161aed1.zip
linhes_pkgbuild-1554ecd8c6978862d012c4fe35295e660161aed1.tar.gz
linhes_pkgbuild-1554ecd8c6978862d012c4fe35295e660161aed1.tar.bz2
perl-astro-suntime: update to 0.06
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-astro-suntime/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-astro-suntime/PKGBUILD b/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
new file mode 100644
index 0000000..76a5cfe
--- /dev/null
+++ b/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-astro-suntime'
+pkgver='0.06'
+pkgrel='1'
+pkgdesc="Get Sun Rise and Set Times for any location on the globe"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-time-parsedate')
+makedepends=()
+url='https://metacpan.org/release/Astro-SunTime'
+source=("http://search.cpan.org/CPAN/authors/id/R/RO/ROBF/Astro-SunTime-$pkgver.tar.gz")
+_distdir="Astro-SunTime-$pkgver"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et:
+md5sums=('42cb8c94de8a111ed652196925c22a45')