summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-02-26 03:25:21 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-02-26 03:25:21 (GMT)
commit2bd9722e2fde8f974c64c7e78070ff24944a2112 (patch)
tree75e2070762ad5cbdf3355e54801adf7c63b8bc01 /abs/core/perl_modules
parent7448592596b972aa6a0a412bdaa25992d498814a (diff)
downloadlinhes_pkgbuild-2bd9722e2fde8f974c64c7e78070ff24944a2112.zip
linhes_pkgbuild-2bd9722e2fde8f974c64c7e78070ff24944a2112.tar.gz
linhes_pkgbuild-2bd9722e2fde8f974c64c7e78070ff24944a2112.tar.bz2
perl-yaml-syck: initial inclusion as dep of xmlto
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-yaml-syck/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-yaml-syck/PKGBUILD b/abs/core/perl_modules/perl-yaml-syck/PKGBUILD
new file mode 100644
index 0000000..ab63f2e
--- /dev/null
+++ b/abs/core/perl_modules/perl-yaml-syck/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Maintainer: kevin <kevin@archlinux.org>
+
+pkgname=perl-yaml-syck
+_realname=YAML-Syck
+pkgver=1.17
+pkgrel=1
+pkgdesc="Fast, lightweight YAML loader and dumper"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://search.cpan.org/dist/${_realname}/"
+depends=('perl>=5.10.0')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/A/AV/AVAR/${_realname}-$pkgver.tar.gz)
+md5sums=('f788529ad4b2c2fd037ccdfd5e7a88ab')
+
+build() {
+ cd ${srcdir}/${_realname}-$pkgver
+
+ # install module in vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make test
+}
+
+package() {
+ cd ${srcdir}/${_realname}-$pkgver
+ make install DESTDIR=${pkgdir}
+
+ # remove perllocal.pod and .packlist
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+
+ # license.
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+}
+