summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-30 20:48:52 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-30 20:48:52 (GMT)
commit2d307ff608d766c5fbc0e0866c6a7283c8c95d0b (patch)
tree1e53842ed600eb1b33ab02e2df0be591104d862f /abs/core/perl_modules
parentef09e081ed60351b50ffca59e4702f968d1fd287 (diff)
downloadlinhes_pkgbuild-2d307ff608d766c5fbc0e0866c6a7283c8c95d0b.zip
linhes_pkgbuild-2d307ff608d766c5fbc0e0866c6a7283c8c95d0b.tar.gz
linhes_pkgbuild-2d307ff608d766c5fbc0e0866c6a7283c8c95d0b.tar.bz2
perl-io-html: initial
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-io-html/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-io-html/PKGBUILD b/abs/core/perl_modules/perl-io-html/PKGBUILD
new file mode 100644
index 0000000..7a86226
--- /dev/null
+++ b/abs/core/perl_modules/perl-io-html/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+
+pkgname=perl-io-html
+pkgver=1.001
+pkgrel=3
+pkgdesc="Open an HTML file with automatic charset detection"
+arch=('any')
+url='http://search.cpan.org/dist/IO-HTML'
+depends=('perl')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/C/CJ/CJM/IO-HTML-$pkgver.tar.gz)
+sha1sums=('210b60f438502744c9c31a82329b19a6f9aecf63')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL_MM_OPT="INSTALLDIRS=vendor" \
+ PERL_MB_OPT="--installdirs vendor"
+ cd IO-HTML-$pkgver
+ perl Makefile.PL
+ make
+}
+
+check() {
+ cd IO-HTML-$pkgver
+ make test
+}
+
+package() {
+ cd IO-HTML-$pkgver
+ make DESTDIR="$pkgdir" install
+}