summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-27 23:57:36 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-27 23:57:36 (GMT)
commit317d96153585b62af6c8dc1c570ca78c333bf856 (patch)
tree306abf271e5a36573d492c1aba0028f2d0d34f1c /abs/core/perl_modules
parent58197a1141c3a3b9fd0ba0ae12f14c6a2cab4d50 (diff)
downloadlinhes_pkgbuild-317d96153585b62af6c8dc1c570ca78c333bf856.zip
linhes_pkgbuild-317d96153585b62af6c8dc1c570ca78c333bf856.tar.gz
linhes_pkgbuild-317d96153585b62af6c8dc1c570ca78c333bf856.tar.bz2
perl-net-smtp-ssl: update to 1.04
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-net-smtp-ssl/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-net-smtp-ssl/PKGBUILD b/abs/core/perl_modules/perl-net-smtp-ssl/PKGBUILD
new file mode 100644
index 0000000..74cb0f9
--- /dev/null
+++ b/abs/core/perl_modules/perl-net-smtp-ssl/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id$
+# Maintainer: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
+
+pkgname=perl-net-smtp-ssl
+pkgver=1.04
+pkgrel=2
+pkgdesc="SSL support for Net::SMTP"
+arch=(any)
+url="http://search.cpan.org/dist/Net-SMTP-SSL/"
+license=('GPL' 'PerlArtistic')
+depends=('perl-io-socket-ssl')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Net-SMTP-SSL-$pkgver.tar.gz")
+sha256sums=('7b29c45add19d3d5084b751f7ba89a8e40479a446ce21cfd9cc741e558332a00')
+
+package() {
+ cd "${srcdir}/Net-SMTP-SSL-${pkgver}"
+ # Install module into the vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make DESTDIR="$pkgdir" install || return 1
+
+ # Remove .packlist and perllocal.pod files.
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name 'perllocal.pod' -delete
+}