summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-03-24 16:10:43 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-03-24 16:10:43 (GMT)
commit4a1f42eb677daa566ce121461d0f7487e2e1deaf (patch)
treef04f4c5350811c4c5ee13d0d03f2cf147e6ba705 /abs/core/perl_modules
parent86153d8ec2a51f6f26f0d5b7351346c2449b7f8f (diff)
downloadlinhes_pkgbuild-4a1f42eb677daa566ce121461d0f7487e2e1deaf.zip
linhes_pkgbuild-4a1f42eb677daa566ce121461d0f7487e2e1deaf.tar.gz
linhes_pkgbuild-4a1f42eb677daa566ce121461d0f7487e2e1deaf.tar.bz2
perl-class-std-fast: initial inclusion. dep of zoneminder
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-class-std-fast/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-class-std-fast/PKGBUILD b/abs/core/perl_modules/perl-class-std-fast/PKGBUILD
new file mode 100644
index 0000000..71878e6
--- /dev/null
+++ b/abs/core/perl_modules/perl-class-std-fast/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname='perl-class-std-fast'
+pkgver='0.0.8'
+pkgrel='1'
+pkgdesc="Class::Std::Fast allows you to use the beautiful API of Class::Std in a faster way than Class::Std"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl' 'perl-class-std')
+makedepends=()
+url='http://search.cpan.org/~acid/Class-Std-Fast/'
+source=('http://search.cpan.org/CPAN/authors/id/A/AC/ACID/Class-Std-Fast-v0.0.8.tar.gz')
+_distdir="Class-Std-Fast-v0.0.8"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+md5sums=('d06d084cb84f295b0aabf2eee78ef746')