summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-30 20:10:35 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-30 20:10:35 (GMT)
commit5c1b86f1d3acbc0d08c84b045f3440f92ce0d35c (patch)
tree8dd65d5ca2e15d0b9c032a45bfee2c243fc9b18c /abs/core/perl_modules
parent20447916cbb13924b4ccd18265b615618ad0e4dd (diff)
downloadlinhes_pkgbuild-5c1b86f1d3acbc0d08c84b045f3440f92ce0d35c.zip
linhes_pkgbuild-5c1b86f1d3acbc0d08c84b045f3440f92ce0d35c.tar.gz
linhes_pkgbuild-5c1b86f1d3acbc0d08c84b045f3440f92ce0d35c.tar.bz2
perl-expect: update to 1.33
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-expect/PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/abs/core/perl_modules/perl-expect/PKGBUILD b/abs/core/perl_modules/perl-expect/PKGBUILD
index 06e8c89..ea14b88 100644
--- a/abs/core/perl_modules/perl-expect/PKGBUILD
+++ b/abs/core/perl_modules/perl-expect/PKGBUILD
@@ -1,22 +1,20 @@
-# CPAN Name : Expect
-# Contributor: Max Roder <maxroder@web.de>
-# Contributor: DarkHeart
-# Generator : CPANPLUS::Dist::Arch 1.19
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-expect'
-pkgver='1.21'
-pkgrel='2'
-pkgdesc="Perl version of Don Libes' Tcl-Expect"
+pkgver='1.33'
+pkgrel='1'
+pkgdesc="automate interactions with command line programs that expose a text terminal interface."
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-depends=('perl-io-tty>=1.03')
+depends=('perl-io-tty' 'perl>=5.6.0')
makedepends=()
-url='http://search.cpan.org/dist/Expect'
-source=('http://search.cpan.org/CPAN/authors/id/R/RG/RGIERSIG/Expect-1.21.tar.gz')
-md5sums=('a151b0dc4d1a35c73941c65b7c26da5b')
-sha512sums=('496716b9e6544e9d6809b7f704df8199291d18ec9ec9ebb4fd2b7b341aa10d9b03989335c1f22d1faddbff0974ceba5b2823685fa08ce6a75e2f3ccaeb944e74')
-_distdir="${srcdir}/Expect-1.21"
+url='https://metacpan.org/release/Expect'
+source=('http://search.cpan.org/CPAN/authors/id/J/JA/JACOBY/Expect-1.33.tar.gz')
+md5sums=('1fbb052de1383966a3be5f420a34e83c')
+sha512sums=('6351e681d813a98cf12a882cb135c6dc5f38beb72fb96efe13c690b26704acb9c5654b2f27dd833ad078de83cb4144fef4aea381a768c54f9817247210e6b5bf')
+_distdir="expect.pm-Expect-1.33"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -25,22 +23,23 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$_distdir"
+ cd "$srcdir/$_distdir"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "$_distdir"
+ cd "$srcdir/$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "$_distdir"
+ cd "$srcdir/$_distdir"
make install
+
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}