summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-08-05 00:34:34 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-08-05 00:34:34 (GMT)
commit6cd1392031d07af98179dfcb300ed89423e77f15 (patch)
tree4b590427fb164907298cef25094ebf404c85afe7 /abs/core/perl_modules
parente5564146f3fb0615f0ca00deeb20ff69f4d016fa (diff)
downloadlinhes_pkgbuild-6cd1392031d07af98179dfcb300ed89423e77f15.zip
linhes_pkgbuild-6cd1392031d07af98179dfcb300ed89423e77f15.tar.gz
linhes_pkgbuild-6cd1392031d07af98179dfcb300ed89423e77f15.tar.bz2
perl-error: Bump to latest.
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-error/PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/abs/core/perl_modules/perl-error/PKGBUILD b/abs/core/perl_modules/perl-error/PKGBUILD
index c804210..2a4437c 100644
--- a/abs/core/perl_modules/perl-error/PKGBUILD
+++ b/abs/core/perl_modules/perl-error/PKGBUILD
@@ -1,27 +1,35 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id$
# Maintainer: Dale Blount <dale@archlinux.org>
# Contributor: Dale Blount <dale@archlinux.org>
pkgname=perl-error
_realname=Error
-pkgver=0.17015
-pkgrel=1
+pkgver=0.17016
+pkgrel=2
pkgdesc="Perl/CPAN Error module - Error/exception handling in an OO-ish way"
url="http://search.cpan.org/dist/${_realname}/"
-arch=(i686 x86_64)
+arch=(any)
license=('PerlArtistic' 'GPL')
depends=('perl>=5.10.0')
options=('!emptydirs')
source=(http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/${_realname}-${pkgver}.tar.gz)
+md5sums=('eedcd3c6970568dd32092b5334328eff')
build() {
- cd ${startdir}/src/${_realname}-${pkgver}
+ cd ${srcdir}/${_realname}-${pkgver}
# install module in vendor directories.
- perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=${startdir}/pkg || return 1
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make test
+}
+
+package() {
+ cd ${srcdir}/${_realname}-${pkgver}
+
+ make install DESTDIR=${pkgdir}
# remove perllocal.pod and .packlist
- find ${startdir}/pkg -name perllocal.pod -delete
- find ${startdir}/pkg -name .packlist -delete
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
}
+